summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-12-26 13:14:21 -0200
committerDaniel Bermond2017-12-27 11:12:06 -0200
commit6b32b2f07c2dc519844cc760414593b45cf11c82 (patch)
tree8cdfff888e91569903b826d2be362043df537831
parent5e0d4f812dead9a29c2443da60332c4fb9a4b5f9 (diff)
downloadaur-6b32b2f07c2dc519844cc760414593b45cf11c82.tar.gz
Add opencl files
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c566bf86ba0d..0a4db6ac3ace 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Aug 7 01:17:49 UTC 2017
+# Wed Dec 27 13:11:35 UTC 2017
pkgbase = intel-media-sdk
pkgdesc = Intel Media SDK (only SDK files, no kernel patches, no system modifications)
pkgver = 2017.R3
- pkgrel = 1
+ pkgrel = 2
url = https://software.intel.com/en-us/intel-media-server-studio/
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index c73662c84c4c..29a14f6c1e57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ _release=R3
_sdkver=16.5.2
pkgname=intel-media-sdk
pkgver="${_year}.${_release}"
-pkgrel=1
+pkgrel=2
pkgdesc='Intel Media SDK (only SDK files, no kernel patches, no system modifications)'
arch=('x86_64')
url='https://software.intel.com/en-us/intel-media-server-studio/'
@@ -28,11 +28,15 @@ prepare() {
cd "${srcdir}/MediaServerStudioEssentials${_year}${_release}/SDK${_year}Production${_sdkver}/Generic"
bsdtar -xf intel-linux-media_generic_"$_sdkver"-*_64bit.tar.gz
+ bsdtar -xf intel-opencl-cpu-*.x86_64.tar.xz
+ bsdtar -xf intel-opencl-devel-*.x86_64.tar.xz
+ bsdtar -xf intel-opencl-r*.x86_64.tar.xz
}
package() {
+ mkdir -p "$pkgdir"/etc/OpenCL
mkdir -p "$pkgdir"/opt/intel/mediasdk/{doc,include/mfx,lib/lin_x64,lib64,plugins,tools}
- mkdir -p "$pkgdir"/usr/{include,lib}/intel-media-sdk
+ mkdir -p "$pkgdir"/usr/{include,lib}/"$pkgname"
# copy SDK files
cd "MediaServerStudioEssentials${_year}${_release}/SDK${_year}Production${_sdkver}/Generic/opt/intel/mediasdk"
@@ -48,8 +52,8 @@ package() {
install -D -m777 mdf/lib64/* "${pkgdir}/opt/intel/mediasdk/lib64"
cd "${srcdir}/MediaServerStudioEssentials${_year}${_release}/SDK${_year}Production${_sdkver}/Generic/usr"
- cp -af include/* "${pkgdir}/usr/include/intel-media-sdk"
- cp -af lib64/* "${pkgdir}/usr/lib/intel-media-sdk"
+ cp -af include/* "${pkgdir}/usr/include/${pkgname}"
+ cp -af lib64/* "${pkgdir}/usr/lib/${pkgname}"
cd "${pkgdir}/opt/intel/mediasdk/include/mfx"
for _file in *
@@ -59,15 +63,22 @@ package() {
cd mfx
done
+ cd "${srcdir}/MediaServerStudioEssentials${_year}${_release}/SDK${_year}Production${_sdkver}/Generic/opt/intel"
+ cp -af opencl "${pkgdir}/opt/intel"
+ cd "${srcdir}/MediaServerStudioEssentials${_year}${_release}/SDK${_year}Production${_sdkver}/Generic/etc/OpenCL"
+ cp -af vendors "${pkgdir}/etc/OpenCL"
+
# copy license files
cd "${srcdir}/MediaServerStudioEssentials${_year}${_release}"
pdftotext -layout 'Intel(R)_Media_Server_Studio_EULA.pdf'
install -D -m644 'Intel(R)_Media_Server_Studio_EULA.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 'redist.txt' "${pkgdir}/usr/share/licenses/${pkgname}/redist.txt"
+ mv "${pkgdir}/opt/intel/opencl/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-opencl"
+ mv "${pkgdir}/opt/intel/opencl/NOTICES" "${pkgdir}/usr/share/licenses/${pkgname}/NOTICES-opencl"
# create a pkgconfig file for libmfx
- local _mfxver_major="$(grep '#define MFX_VERSION_MAJOR' "${pkgdir}/opt/intel/mediasdk/include/mfx/mfxvideo.h" | cut -d' ' -f3)"
- local _mfxver_minor="$(grep '#define MFX_VERSION_MINOR' "${pkgdir}/opt/intel/mediasdk/include/mfx/mfxvideo.h" | cut -d' ' -f3)"
+ local _mfxver_major="$(grep '#define MFX_VERSION_MAJOR' "${pkgdir}/opt/intel/mediasdk/include/mfx/mfxvideo.h" | awk '{ print $3 }')"
+ local _mfxver_minor="$(grep '#define MFX_VERSION_MINOR' "${pkgdir}/opt/intel/mediasdk/include/mfx/mfxvideo.h" | awk '{ print $3 }')"
local _mfxver="${_mfxver_major}.${_mfxver_minor}"
mkdir -p "${pkgdir}/opt/intel/mediasdk/lib/pkgconfig"
touch "${pkgdir}/opt/intel/mediasdk/lib/pkgconfig/libmfx.pc"