summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-02-09 21:52:14 -0200
committerDaniel Bermond2018-02-09 21:57:35 -0200
commit00002b3d1503e2482b9ebc68b5472f3c5959c9a8 (patch)
tree05d1c520a43f768509cf788b8596dcc33aa952e9
parent43ce51a7969eb1a949a053585329a6f7a1351f79 (diff)
downloadaur-00002b3d1503e2482b9ebc68b5472f3c5959c9a8.tar.gz
Change plugins directory
This will change the plugins directory from the non-standard path '/usr/plugins' to the standard path '/usr/lib', removing the need of symbolic links for plugins in '/usr/lib'.
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD16
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac06660bef4b..427b051c87f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = intel-media-sdk-git
pkgdesc = API to access hardware-accelerated video decode, encode and filtering on Intel platforms with integrated graphics (git version)
- pkgver = 1.2a.r40.gff56d31
+ pkgver = 1.2a.r44.gbb93dc5
pkgrel = 1
url = https://github.com/Intel-Media-SDK/MediaSDK/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 6340823d6a59..8666c310fab0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=intel-media-sdk-git
-pkgver=1.2a.r40.gff56d31
+pkgver=1.2a.r44.gbb93dc5
pkgrel=1
pkgdesc='API to access hardware-accelerated video decode, encode and filtering on Intel platforms with integrated graphics (git version)'
arch=('x86_64')
@@ -47,6 +47,13 @@ prepare() {
patch -Np1 -i "${srcdir}/${_patch}"
fi
done
+
+ # change plugins directory
+ if ! grep -q '^set(MFX_PLUGINS_DIR[[:space:]]/usr/lib64)$' CMakeLists.txt
+ then
+ sed -i '20i\\' CMakeLists.txt
+ sed -i '21iset(MFX_PLUGINS_DIR /usr/lib64)' CMakeLists.txt
+ fi
}
pkgver() {
@@ -93,13 +100,6 @@ package() {
cd ..
done
- # plugins
- cd "${pkgdir}/usr/plugins"
- for _plugin in *
- do
- ln -sf ../plugins/"$_plugin" ../lib/"$_plugin"
- done
-
# move samples to a better place
mv -f "${pkgdir}/usr/samples" "${pkgdir}/usr/lib/${pkgname}"