summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-02-06 13:37:58 -0200
committerDaniel Bermond2018-02-06 13:41:19 -0200
commit43ce51a7969eb1a949a053585329a6f7a1351f79 (patch)
treed6af1e78b9b3fe62071f6c636d9566b55753b2a4
parent08a4e44b91ab4876fe04ee1ae0271cbc07a653cc (diff)
downloadaur-43ce51a7969eb1a949a053585329a6f7a1351f79.tar.gz
Remove libraries patch and pkgconfig fix (both fixed by upstream)
References ---------- https://github.com/Intel-Media-SDK/MediaSDK/commit/ff56d317d86836e6413baee2d17bbe8ea0b8ba0a https://github.com/Intel-Media-SDK/MediaSDK/commit/1ef56566371128363be269b02faaf0f919fc1734
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD33
-rw-r--r--intel-media-sdk-add-runtime-libraries.patch10
3 files changed, 13 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bbad522eb04..ac06660bef4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = intel-media-sdk-git
pkgdesc = API to access hardware-accelerated video decode, encode and filtering on Intel platforms with integrated graphics (git version)
- pkgver = 1.2a.r16.gc3ba904
+ pkgver = 1.2a.r40.gff56d31
pkgrel = 1
url = https://github.com/Intel-Media-SDK/MediaSDK/
arch = x86_64
@@ -18,10 +18,8 @@ pkgbase = intel-media-sdk-git
conflicts = libmfx
source = intel-media-sdk-change-gcc-version.patch
source = intel-media-sdk-detect-intel-opencl.patch
- source = intel-media-sdk-add-runtime-libraries.patch
sha256sums = d9fc114d06624504891b545df2913b01d4b07edfb99512388490eae40f9b9ab7
sha256sums = 689ebc270532c0e1e5132d39898ff2a93fe3483a5a2673aea396a24fc07ad24c
- sha256sums = 8bbbbe1729c54980103c7ab76815a565df7427ce44bd2789c891a1d521e1f737
pkgname = intel-media-sdk-git
diff --git a/PKGBUILD b/PKGBUILD
index ee7d5b6fe60c..6340823d6a59 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=intel-media-sdk-git
-pkgver=1.2a.r16.gc3ba904
+pkgver=1.2a.r40.gff56d31
pkgrel=1
pkgdesc='API to access hardware-accelerated video decode, encode and filtering on Intel platforms with integrated graphics (git version)'
arch=('x86_64')
@@ -20,11 +20,9 @@ makedepends=(
provides=('intel-media-sdk' 'libmfx')
conflicts=('intel-media-sdk' 'libmfx')
source=('intel-media-sdk-change-gcc-version.patch'
- 'intel-media-sdk-detect-intel-opencl.patch'
- 'intel-media-sdk-add-runtime-libraries.patch')
+ 'intel-media-sdk-detect-intel-opencl.patch')
sha256sums=('d9fc114d06624504891b545df2913b01d4b07edfb99512388490eae40f9b9ab7'
- '689ebc270532c0e1e5132d39898ff2a93fe3483a5a2673aea396a24fc07ad24c'
- '8bbbbe1729c54980103c7ab76815a565df7427ce44bd2789c891a1d521e1f737')
+ '689ebc270532c0e1e5132d39898ff2a93fe3483a5a2673aea396a24fc07ad24c')
prepare() {
# makepkg does not support cloning git-lfs repositories
@@ -41,8 +39,7 @@ prepare() {
fi
for _patch in intel-media-sdk-change-gcc-version.patch \
- intel-media-sdk-detect-intel-opencl.patch \
- intel-media-sdk-add-runtime-libraries.patch
+ intel-media-sdk-detect-intel-opencl.patch
do
printf '%s\n' "Checking patch '${_patch}'"
if patch -Np1 --dry-run -i "${srcdir}/${_patch}" >/dev/null
@@ -70,7 +67,7 @@ build() {
perl tools/builder/build_mfx.pl \
--no-warn-as-error \
--cmake='intel64.make.release' \
- --prefix='/usr' \
+ --prefix='/usr'
make -C __cmake/intel64.make.release
}
@@ -87,16 +84,7 @@ package() {
mkdir -p "${pkgdir}/usr/"{include/mfx,lib/"$pkgname"}
- # move samples to a better place
- mv -f "${pkgdir}/usr/samples" "${pkgdir}/usr/lib/${pkgname}"
-
- # license
- cd "${srcdir}/${pkgname}"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- # bellow are fixes for ffmpeg (some paths are hardcoded, use symlinks)
-
- # includes
+ # includes (add 'mfx' folder for ffmpeg compatibility)
cd "${pkgdir}/usr/include"
for _header in *.h
do
@@ -112,7 +100,10 @@ package() {
ln -sf ../plugins/"$_plugin" ../lib/"$_plugin"
done
- # pkgconfig file
- cd "${pkgdir}/usr/lib/pkgconfig"
- ln -sf mfx.pc libmfx.pc
+ # move samples to a better place
+ mv -f "${pkgdir}/usr/samples" "${pkgdir}/usr/lib/${pkgname}"
+
+ # license
+ cd "${srcdir}/${pkgname}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/intel-media-sdk-add-runtime-libraries.patch b/intel-media-sdk-add-runtime-libraries.patch
deleted file mode 100644
index f36ba086f12f..000000000000
--- a/intel-media-sdk-add-runtime-libraries.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -Naur a/api/opensource/mfx_dispatch/pkg-config.pc.cmake b/api/opensource/mfx_dispatch/pkg-config.pc.cmake
---- a/api/opensource/mfx_dispatch/pkg-config.pc.cmake 2018-01-15 16:40:45.000000000 -0200
-+++ b/api/opensource/mfx_dispatch/pkg-config.pc.cmake 2018-01-15 16:42:42.410556038 -0200
-@@ -5,5 +5,5 @@
- prefix=@CMAKE_INSTALL_PREFIX@
- libdir=@CMAKE_INSTALL_FULL_LIBDIR@
- includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
--Libs: -L${libdir} -lmfx
-+Libs: -L${libdir} -lmfx -lstdc++ -ldl
- Cflags: -I${includedir}