summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-02-22 13:42:11 -0300
committerDaniel Bermond2018-02-22 13:42:11 -0300
commite9d28f21661961b49ef877373e5f0b2a925df40b (patch)
tree5a2e639e6dae2ff1b82d0fafe665f0188dbd3219
parentdc2fcb84e0d27e57921b17fbd33eeaa202a26552 (diff)
downloadaur-e9d28f21661961b49ef877373e5f0b2a925df40b.tar.gz
Remove intel opencl patch (fixed by upstream)
Upstream now checks in cmake time if intel opencl is installed on the system and disables the building of the corresponding sample if it was not found, avoiding a compile error. References ---------- https://github.com/Intel-Media-SDK/MediaSDK/commit/cb58f7d7e9994ef6167ecadef9feaf023cf6481b
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD15
-rw-r--r--intel-media-sdk-detect-intel-opencl.patch57
3 files changed, 4 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83771c6c6727..35cbbfeb2b00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = intel-media-sdk-git
pkgdesc = API to access hardware-accelerated video decode, encode and filtering on Intel platforms with integrated graphics (git version)
- pkgver = 1.2a.r49.g78bf771
- pkgrel = 2
+ pkgver = 1.2a.r55.g22dae39
+ pkgrel = 1
url = https://github.com/Intel-Media-SDK/MediaSDK/
arch = x86_64
license = MIT
@@ -15,8 +15,6 @@ pkgbase = intel-media-sdk-git
provides = libmfx
conflicts = intel-media-sdk
conflicts = libmfx
- source = intel-media-sdk-detect-intel-opencl.patch
- sha256sums = 689ebc270532c0e1e5132d39898ff2a93fe3483a5a2673aea396a24fc07ad24c
pkgname = intel-media-sdk-git
diff --git a/PKGBUILD b/PKGBUILD
index f20f82cb4ee7..91514a501b1b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
# Currently it will not be a mandatory makedepend.
pkgname=intel-media-sdk-git
-pkgver=1.2a.r49.g78bf771
-pkgrel=2
+pkgver=1.2a.r55.g22dae39
+pkgrel=1
pkgdesc='API to access hardware-accelerated video decode, encode and filtering on Intel platforms with integrated graphics (git version)'
arch=('x86_64')
url='https://github.com/Intel-Media-SDK/MediaSDK/'
@@ -26,8 +26,6 @@ makedepends=(
)
provides=('intel-media-sdk' 'libmfx')
conflicts=('intel-media-sdk' 'libmfx')
-source=('intel-media-sdk-detect-intel-opencl.patch')
-sha256sums=('689ebc270532c0e1e5132d39898ff2a93fe3483a5a2673aea396a24fc07ad24c')
prepare() {
# makepkg does not support cloning git-lfs repositories
@@ -43,15 +41,6 @@ prepare() {
cd "$pkgname"
fi
- for _patch in intel-media-sdk-detect-intel-opencl.patch
- do
- printf '%s\n' "Checking patch '${_patch}'"
- if patch -Np1 --dry-run -i "${srcdir}/${_patch}" >/dev/null
- then
- patch -Np1 -i "${srcdir}/${_patch}"
- fi
- done
-
# change plugins directory
if ! grep -q '^set(MFX_PLUGINS_DIR[[:space:]]/usr/lib64)$' CMakeLists.txt
then
diff --git a/intel-media-sdk-detect-intel-opencl.patch b/intel-media-sdk-detect-intel-opencl.patch
deleted file mode 100644
index 0a27405971a5..000000000000
--- a/intel-media-sdk-detect-intel-opencl.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From f16a0707bf8db4d9078af3b1f0f50f9d64532911 Mon Sep 17 00:00:00 2001
-From: Ruiling Song <ruiling.song@intel.com>
-Date: Tue, 5 Dec 2017 14:31:00 +0800
-Subject: [PATCH] Detect Intel OpenCL SDK exactly.
-
-the rotate_opencl sample tries to access "CL/va_ext.h".
-which is Intel OpenCL SDK specific extension.
-So let's try to only build the sample if user has installed
-Intel OpenCL SDK.
-
-v2:
-slight update the cmake to move make_library under INTEL_OPENCL_SDK.
-
-Signed-off-by: Ruiling Song <ruiling.song@intel.com>
----
- builder/FindOpenCL.cmake | 8 ++++++++
- samples/sample_plugins/rotate_opencl/CMakeLists.txt | 6 +++---
- 2 files changed, 11 insertions(+), 3 deletions(-)
-
-diff --git a/builder/FindOpenCL.cmake b/builder/FindOpenCL.cmake
-index f763155..7fcd552 100644
---- a/builder/FindOpenCL.cmake
-+++ b/builder/FindOpenCL.cmake
-@@ -23,6 +23,14 @@ find_library( OPENCL_LIBRARY libOpenCL.so PATHS /usr/lib /opt/intel/opencl/)
-
- set( OCL_LIBS "" )
-
-+if ( EXISTS /etc/OpenCL/vendors/intel.icd )
-+ message( STATUS "Intel OpenCL SDK found")
-+ set ( INTEL_OPENCL_SDK TRUE )
-+else ()
-+ message( STATUS "Intel OpenCL SDK not found")
-+ set ( INTEL_OPENCL_SDK FALSE )
-+endif()
-+
- if ( NOT OPENCL_INCLUDE MATCHES NOTFOUND )
- if ( NOT OPENCL_LIBRARY MATCHES NOTFOUND )
- set ( OPENCL_FOUND TRUE )
-diff --git a/samples/sample_plugins/rotate_opencl/CMakeLists.txt b/samples/sample_plugins/rotate_opencl/CMakeLists.txt
-index d06400c..1818c87 100644
---- a/samples/sample_plugins/rotate_opencl/CMakeLists.txt
-+++ b/samples/sample_plugins/rotate_opencl/CMakeLists.txt
-@@ -17,11 +17,11 @@ list( APPEND LIBS_VARIANT sample_common )
- list(APPEND sources.plus "${PLUGINS_COMMON_PATH}/mfx_plugin_module.cpp")
-
- set(DEPENDENCIES opencl libva libmfx dl)
--make_library( sample_plugin_opencl none shared "nosafestring" )
-
--install( TARGETS ${target} LIBRARY DESTINATION ${MFX_SAMPLES_INSTALL_LIB_DIR} )
-+if ( INTEL_OPENCL_SDK )
-+ make_library( sample_plugin_opencl none shared "nosafestring" )
-
--if ( DEFINED OPENCL_FOUND )
-+ install( TARGETS ${target} LIBRARY DESTINATION ${MFX_SAMPLES_INSTALL_LIB_DIR} )
- # copy .cl file into build directory
- execute_process( COMMAND ${CMAKE_COMMAND} -E copy
- "${CMAKE_CURRENT_SOURCE_DIR}/src/ocl_rotate.cl"