summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-08-07 15:15:08 +0000
committerDaniel Bermond2018-08-07 15:15:08 +0000
commiteaa35c663a045a59ecded8c803335323029f6608 (patch)
tree354408de4c075afbcca2db64e161670557a43228
parentee041ceba8b7b838ae8272b1ccdf60f440b25421 (diff)
downloadaur-eaa35c663a045a59ecded8c803335323029f6608.tar.gz
Revert directory changes of commit b720fc6
There is no new directory schema in pacman 5.1.0. There is actually a bug in pacman 5.1.0 when using directories with symlinks in the building path. This bug was fixed in pacman 5.1.1 and we can revert these changes. References ---------- https://bugs.archlinux.org/task/58865 https://bbs.archlinux.org/viewtopic.php?pid=1789530#p1789530 https://bbs.archlinux.org/viewtopic.php?id=237706 https://bbs.archlinux.org/viewtopic.php?id=238260 https://lists.archlinux.org/pipermail/pacman-dev/2018-June/022579.html
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD23
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 123e15e04d3d..53354ca2ba99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = intel-media-sdk-git
pkgdesc = API to access hardware-accelerated video decode, encode and filtering on Intel platforms with integrated graphics (git version)
pkgver = 2018.Q2.1.r215.g7885aa1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Intel-Media-SDK/MediaSDK/
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 8fc76c420661..325965d28a34 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,9 @@
# intel-seapi will be autodetected by the build system, serving as a makedepend.
# Currently it will not be a mandatory makedepend.
-_srcname=MediaSDK
pkgname=intel-media-sdk-git
pkgver=2018.Q2.1.r215.g7885aa1
-pkgrel=1
+pkgrel=2
pkgdesc='API to access hardware-accelerated video decode, encode and filtering on Intel platforms with integrated graphics (git version)'
arch=('x86_64')
url='https://github.com/Intel-Media-SDK/MediaSDK/'
@@ -28,21 +27,21 @@ options=('!emptydirs')
prepare() {
# makepkg does not support cloning git-lfs repositories
- if [ -d "$_srcname" ]
+ if [ -d "$pkgname" ]
then
- msg2 "Updating ${_srcname} git repo..."
- cd "$_srcname"
+ msg2 "Updating ${pkgname} git repo..."
+ cd "$pkgname"
git pull origin
else
- msg2 "Cloning ${_srcname} git repo..."
+ msg2 "Cloning ${pkgname} git repo..."
git lfs install
- git clone https://github.com/Intel-Media-SDK/MediaSDK.git
- cd "$_srcname"
+ git clone https://github.com/Intel-Media-SDK/MediaSDK.git "$pkgname"
+ cd "$pkgname"
fi
}
pkgver() {
- cd "$_srcname"
+ cd "$pkgname"
# git, tags available
local _prefix='MediaSDK-'
@@ -50,7 +49,7 @@ pkgver() {
}
build() {
- cd "$_srcname"
+ cd "$pkgname"
mkdir -p build
cd build
@@ -79,11 +78,11 @@ build() {
}
package() {
- cd "${_srcname}/build"
+ cd "${pkgname}/build"
make DESTDIR="$pkgdir" install
# license
- cd "${srcdir}/${_srcname}"
+ cd "${srcdir}/${pkgname}"
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}