summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-10-20 20:23:28 +0000
committerDaniel Bermond2018-10-20 20:25:26 +0000
commit879f760b829c48238199d9714cf2d4fdd6d6ca0a (patch)
tree24b9a6159343865777919ab4abceb72f3ed10706
parent67f81483085b83c2df6a4322180d722b4cb21546 (diff)
downloadaur-879f760b829c48238199d9714cf2d4fdd6d6ca0a.tar.gz
Fixes
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a3641db859a..9b3d12d464f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = intel-media-server-studio
pkgdesc = Intel Media Server Studio (only SDK files, no kernel patches, no system modifications)
pkgver = 2018.R1
- pkgrel = 3
+ pkgrel = 4
url = https://software.intel.com/en-us/intel-media-server-studio/
arch = x86_64
license = custom
@@ -12,7 +12,6 @@ pkgbase = intel-media-server-studio
conflicts = intel-opencl
conflicts = intel-opencl-runtime
conflicts = intel-media-sdk
- conflicts = intel-media-sdk-git
options = !strip
options = staticlibs
source = http://registrationcenter-download.intel.com/akdlm/irc_nas/vcp/12841/MediaServerStudioEssentials2018R1.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 76cf56a23a66..90593d84ed1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer: Daniel Bermond < gmail-com: danielbermond >
# NOTE:
# This package provides only the SDK files for Intel Media Server Studio.
@@ -12,14 +12,14 @@ _release=R1
_sdkver=16.8
pkgname=intel-media-server-studio
pkgver="${_year}.${_release}"
-pkgrel=3
+pkgrel=4
pkgdesc='Intel Media Server Studio (only SDK files, no kernel patches, no system modifications)'
arch=('x86_64')
url='https://software.intel.com/en-us/intel-media-server-studio/'
license=('custom')
makedepends=('poppler')
provides=('intel-opencl' 'intel-opencl-runtime' 'intel-media-sdk')
-conflicts=('intel-opencl' 'intel-opencl-runtime' 'intel-media-sdk' 'intel-media-sdk-git')
+conflicts=('intel-opencl' 'intel-opencl-runtime' 'intel-media-sdk')
options=('!strip' 'staticlibs')
source=("http://registrationcenter-download.intel.com/akdlm/irc_nas/vcp/12841/MediaServerStudioEssentials${_year}${_release}.tar.gz")
sha256sums=('2bb4a8d2235203f4943a19398feb51c4a07b9f60f1e11da8d4aff2b8c7eb2187')
@@ -54,6 +54,7 @@ package() {
sed -i '1s/^/#/' "${pkgdir}/etc/profile.d/libintelopencl.sh"
# add 'mfx' include folder for ffmpeg compatibility
+ local _header
mkdir -p "${pkgdir}/opt/intel/mediasdk/include/mfx"
cd "${pkgdir}/opt/intel/mediasdk/include"
for _header in *.h
@@ -72,9 +73,12 @@ package() {
mv "${pkgdir}/opt/intel/opencl/NOTICES" "${pkgdir}/usr/share/licenses/${pkgname}/NOTICES-opencl"
# create a pkgconfig file for libmfx
- local _mfxver_major="$(grep '#define MFX_VERSION_MAJOR' "${pkgdir}/opt/intel/mediasdk/include/mfxdefs.h" | awk '{ print $3 }')"
- local _mfxver_minor="$(grep '#define MFX_VERSION_MINOR' "${pkgdir}/opt/intel/mediasdk/include/mfxdefs.h" | awk '{ print $3 }')"
- local _mfxver="${_mfxver_major}.${_mfxver_minor}"
+ local _mfxver_major
+ local _mfxver_minor
+ local _mfxver
+ _mfxver_major="$(grep '#define MFX_VERSION_MAJOR' "${pkgdir}/opt/intel/mediasdk/include/mfxdefs.h" | awk '{ print $3 }')"
+ _mfxver_minor="$(grep '#define MFX_VERSION_MINOR' "${pkgdir}/opt/intel/mediasdk/include/mfxdefs.h" | awk '{ print $3 }')"
+ _mfxver="${_mfxver_major}.${_mfxver_minor}"
mkdir -p "${pkgdir}/opt/intel/mediasdk/lib/pkgconfig"
touch "${pkgdir}/opt/intel/mediasdk/lib/pkgconfig/libmfx.pc"
chmod 644 "${pkgdir}/opt/intel/mediasdk/lib/pkgconfig/libmfx.pc"