summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-04-15 01:58:31 +0000
committerDaniel Bermond2018-04-15 01:58:31 +0000
commitc113b861c5b466ccb9729743c28ccb352664ff45 (patch)
tree6bab6dbd1de3e1f18d574d6fd900aef6457987ae
parent48813ae01fe3660c1580c92d6d9ab5be99c5012d (diff)
downloadaur-c113b861c5b466ccb9729743c28ccb352664ff45.tar.gz
Updated to version 2018.R1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD69
2 files changed, 35 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 930be28b3402..945fc6fe9b1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu Jan 4 13:56:33 UTC 2018
pkgbase = intel-media-server-studio
pkgdesc = Intel Media Server Studio (only SDK files, no kernel patches, no system modifications)
- pkgver = 2017.R3
- pkgrel = 2
+ pkgver = 2018.R1
+ pkgrel = 1
url = https://software.intel.com/en-us/intel-media-server-studio/
arch = x86_64
license = custom
@@ -14,8 +12,8 @@ pkgbase = intel-media-server-studio
conflicts = intel-opencl-runtime
options = !strip
options = staticlibs
- source = http://registrationcenter-download.intel.com/akdlm/irc_nas/vcp/11800/MediaServerStudioEssentials2017R3.tar.gz
- sha256sums = 3037eabad6621c43e1b4ba3e85a06fafd7d494924e0c3b94fbaf3bc675852960
+ source = http://registrationcenter-download.intel.com/akdlm/irc_nas/vcp/12841/MediaServerStudioEssentials2018R1.tar.gz
+ sha256sums = 2bb4a8d2235203f4943a19398feb51c4a07b9f60f1e11da8d4aff2b8c7eb2187
pkgname = intel-media-server-studio
diff --git a/PKGBUILD b/PKGBUILD
index 76667200b2b9..75b7b025827f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
# NOTE:
# This package provides only the SDK files for Intel Media Server Studio.
# The proper installation requires a specific (older) Linux kernel version,
-# kernel patches and other system modifications. For the sake of the system
-# this package will not touch the kernel or system libraries. Only the SDK
-# files will be provided in '/opt'.
+# kernel patches and other system modifications. For the sake of the system,
+# this package will not touch the kernel or system libraries. Only the SDK
+# files will be provided.
-_year=2017
-_release=R3
-_sdkver=16.5.2
+_year=2018
+_release=R1
+_sdkver=16.8
pkgname=intel-media-server-studio
pkgver="${_year}.${_release}"
-pkgrel=2
+pkgrel=1
pkgdesc='Intel Media Server Studio (only SDK files, no kernel patches, no system modifications)'
arch=('x86_64')
url='https://software.intel.com/en-us/intel-media-server-studio/'
@@ -21,8 +21,8 @@ makedepends=('poppler')
conflicts=('intel-opencl' 'intel-opencl-runtime')
provides=('intel-opencl' 'intel-opencl-runtime')
options=('!strip' 'staticlibs')
-source=("http://registrationcenter-download.intel.com/akdlm/irc_nas/vcp/11800/MediaServerStudioEssentials${_year}${_release}.tar.gz")
-sha256sums=('3037eabad6621c43e1b4ba3e85a06fafd7d494924e0c3b94fbaf3bc675852960')
+source=("http://registrationcenter-download.intel.com/akdlm/irc_nas/vcp/12841/MediaServerStudioEssentials${_year}${_release}.tar.gz")
+sha256sums=('2bb4a8d2235203f4943a19398feb51c4a07b9f60f1e11da8d4aff2b8c7eb2187')
prepare() {
cd "MediaServerStudioEssentials${_year}${_release}"
@@ -32,44 +32,37 @@ prepare() {
bsdtar -xf intel-linux-media_generic_"$_sdkver"-*_64bit.tar.gz
bsdtar -xf intel-opencl-cpu-*.x86_64.tar.xz
bsdtar -xf intel-opencl-devel-*.x86_64.tar.xz
- bsdtar -xf intel-opencl-r*.x86_64.tar.xz
+ bsdtar -xf intel-opencl-${_sdkver}*.x86_64.tar.xz
}
package() {
- mkdir -p "$pkgdir"/etc/OpenCL
- mkdir -p "$pkgdir"/opt/intel/mediasdk/{doc,include/mfx,lib/lin_x64,lib64,plugins,tools}
+ # directories creation
+ mkdir -p "$pkgdir"/opt/intel
mkdir -p "$pkgdir"/usr/{include,lib}/"$pkgname"
# copy SDK files
- cd "MediaServerStudioEssentials${_year}${_release}/SDK${_year}Production${_sdkver}/Generic/opt/intel/mediasdk"
- install -D -m644 doc/* "${pkgdir}/opt/intel/mediasdk/doc"
- install -D -m644 include/* "${pkgdir}/opt/intel/mediasdk/include/mfx"
- install -D -m777 lib/lin_x64/* "${pkgdir}/opt/intel/mediasdk/lib/lin_x64"
- install -D -m777 lib64/* "${pkgdir}/opt/intel/mediasdk/lib64"
- install -D -m777 plugins/*.so "${pkgdir}/opt/intel/mediasdk/plugins"
- install -D -m644 plugins/plugins.cfg "${pkgdir}/opt/intel/mediasdk/plugins/plugins.cfg"
- cp -af tools/* "${pkgdir}/opt/intel/mediasdk/tools"
-
- cd "${srcdir}/MediaServerStudioEssentials${_year}${_release}/SDK${_year}Production${_sdkver}/Generic/opt/intel/common"
- install -D -m777 mdf/lib64/* "${pkgdir}/opt/intel/mediasdk/lib64"
-
- cd "${srcdir}/MediaServerStudioEssentials${_year}${_release}/SDK${_year}Production${_sdkver}/Generic/usr"
- cp -af include/* "${pkgdir}/usr/include/${pkgname}"
- cp -af lib64/* "${pkgdir}/usr/lib/${pkgname}"
+ cd "${srcdir}/MediaServerStudioEssentials${_year}${_release}/SDK${_year}Production${_sdkver}/Generic"
+ cp -af opt/intel/common "${pkgdir}/opt/intel"
+ cp -af opt/intel/mediasdk "${pkgdir}/opt/intel"
+ cp -af opt/intel/opencl "${pkgdir}/opt/intel"
+ cp -af etc/OpenCL "${pkgdir}/etc"
+ cp -af etc/ld.so.conf.d "${pkgdir}/etc"
+ cp -af usr/include/* "${pkgdir}/usr/include/${pkgname}"
+ cp -af usr/lib64/* "${pkgdir}/usr/lib/${pkgname}"
+ install -D -m644 etc/profile.d/*.sh -t "${pkgdir}/etc/profile.d"
+ sed -i '2,3s/^/#/' "${pkgdir}/etc/profile.d/intel-mediasdk.sh"
+ sed -i '1s/^/#/' "${pkgdir}/etc/profile.d/libintelopencl.sh"
- cd "${pkgdir}/opt/intel/mediasdk/include/mfx"
- for _file in *
+ # add 'mfx' include folder for ffmpeg compatibility
+ mkdir -p "${pkgdir}/opt/intel/mediasdk/include/mfx"
+ cd "${pkgdir}/opt/intel/mediasdk/include"
+ for _header in *.h
do
- cd ..
- ln -sf "mfx/${_file}" "$_file"
cd mfx
+ ln -sf ../"$_header" "$_header"
+ cd ..
done
- cd "${srcdir}/MediaServerStudioEssentials${_year}${_release}/SDK${_year}Production${_sdkver}/Generic/opt/intel"
- cp -af opencl "${pkgdir}/opt/intel"
- cd "${srcdir}/MediaServerStudioEssentials${_year}${_release}/SDK${_year}Production${_sdkver}/Generic/etc/OpenCL"
- cp -af vendors "${pkgdir}/etc/OpenCL"
-
# copy license files
cd "${srcdir}/MediaServerStudioEssentials${_year}${_release}"
pdftotext -layout 'Intel(R)_Media_Server_Studio_EULA.pdf'
@@ -79,8 +72,8 @@ package() {
mv "${pkgdir}/opt/intel/opencl/NOTICES" "${pkgdir}/usr/share/licenses/${pkgname}/NOTICES-opencl"
# create a pkgconfig file for libmfx
- local _mfxver_major="$(grep '#define MFX_VERSION_MAJOR' "${pkgdir}/opt/intel/mediasdk/include/mfx/mfxvideo.h" | awk '{ print $3 }')"
- local _mfxver_minor="$(grep '#define MFX_VERSION_MINOR' "${pkgdir}/opt/intel/mediasdk/include/mfx/mfxvideo.h" | awk '{ print $3 }')"
+ local _mfxver_major="$(grep '#define MFX_VERSION_MAJOR' "${pkgdir}/opt/intel/mediasdk/include/mfxdefs.h" | awk '{ print $3 }')"
+ local _mfxver_minor="$(grep '#define MFX_VERSION_MINOR' "${pkgdir}/opt/intel/mediasdk/include/mfxdefs.h" | awk '{ print $3 }')"
local _mfxver="${_mfxver_major}.${_mfxver_minor}"
mkdir -p "${pkgdir}/opt/intel/mediasdk/lib/pkgconfig"
touch "${pkgdir}/opt/intel/mediasdk/lib/pkgconfig/libmfx.pc"