summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorButter Cat2024-03-04 21:08:00 -0500
committerButter Cat2024-03-04 21:08:00 -0500
commit25cf6168f44fc61b8cdbf19ee3b5bcfd83872f66 (patch)
tree6bf75298a7618510058ca47d3492822f19a305cf
downloadaur-25cf6168f44fc61b8cdbf19ee3b5bcfd83872f66.tar.gz
Initial upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rw-r--r--intellectual.conf13
-rw-r--r--intellectual.service11
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c96ac2283a1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = intellectual-git
+ pkgdesc = An alternative frontend for Genius focused on privacy and simplicity.
+ pkgver = r376.aa4ffb2
+ pkgrel = 1
+ url = https://github.com/Insprill/intellectual
+ arch = x86_64
+ arch = aarch64
+ license = AGPL-3.0-only
+ makedepends = git
+ makedepends = rust
+ provides = intellectual
+ conflicts = intellectual
+ options = !buildflags
+ backup = etc/intellectual.conf
+ source = intellectual::git+https://github.com/Insprill/intellectual
+ sha256sums = SKIP
+
+pkgname = intellectual-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a5df3f794ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Butter Cat <ButteredCats@protonmail.com>
+
+_pkgname="intellectual"
+pkgname="${_pkgname}-git"
+pkgver=r376.aa4ffb2
+pkgrel=1
+pkgdesc="An alternative frontend for Genius focused on privacy and simplicity."
+arch=('x86_64' 'aarch64')
+url="https://github.com/Insprill/intellectual"
+license=('AGPL-3.0-only')
+makedepends=('git' 'rust')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+${url}")
+sha256sums=('SKIP')
+backup=('etc/intellectual.conf')
+options=('!buildflags')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+ cargo build --release
+}
+
+package() {
+ cd "${_pkgname}"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dm644 ../../intellectual.conf -t "${pkgdir}/etc/"
+ install -Dm644 ../../intellectual.service -t "${pkgdir}/usr/lib/systemd/system/"
+ install -Dm755 "target/release/intellectual" "${pkgdir}/usr/bin/"
+}
diff --git a/intellectual.conf b/intellectual.conf
new file mode 100644
index 000000000000..702df3cc6063
--- /dev/null
+++ b/intellectual.conf
@@ -0,0 +1,13 @@
+# intellectual.service uses this file for these options
+
+# Address to bind to
+ADDRESS="0.0.0.0"
+
+# Port to listen on
+PORT="8080"
+
+# Workers to run, 0 equals physical CPU cores
+WORKERS="0"
+
+# Keep alive timeout in seconds
+KEEP_ALIVE_TIMEOUT="15"
diff --git a/intellectual.service b/intellectual.service
new file mode 100644
index 000000000000..e753d0147faf
--- /dev/null
+++ b/intellectual.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=An alternative frontend for Genius focused on privacy and simplicity.
+After=syslog.target
+After=network.target
+
+[Service]
+EnvironmentFile=/etc/intellectual.conf
+ExecStart=/usr/bin/intellectual -a "${ADDRESS}" -p "${PORT}" -w "${WORKERS}" -k "${KEEP_ALIVE_TIMEOUT}"
+
+[Install]
+WantedBy=multi-user.target