summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoriboyperson2018-05-04 20:20:27 -0700
committeriboyperson2018-05-04 20:20:27 -0700
commit2288592fa78be8f6da9fddfe7110cd661ad683be (patch)
tree8a69f363517196fa5a9a0f54150e960572593ae7
downloadaur-2288592fa78be8f6da9fddfe7110cd661ad683be.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rw-r--r--jetbrains-idea-ce.desktop10
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f6f3979184b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = intellij-idea-community-edition-no-jre
+ pkgdesc = Intellij Idea Community Edition without bundled JRE
+ pkgver = 2018.1.2
+ pkgrel = 1
+ url = http://www.jetbrains.com/idea/
+ arch = any
+ license = Apache2
+ depends = giflib
+ depends = libxtst
+ depends = java-environment
+ provides = jetbrains-idea-ce
+ conflicts = jetbrains-idea-ce
+ options = !strip
+ source = https://download.jetbrains.com/idea/ideaIC-2018.1.2-no-jdk.tar.gz
+ source = jetbrains-idea-ce.desktop
+ md5sums = 752568aae86e97470d01a5aaab5d3521
+ md5sums = 9e5798fd87d09fa8f2f24721b6af4d5f
+
+pkgname = intellij-idea-community-edition-no-jre
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb1284d20648
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Thomas Quillan <tjquillan@gmail.com>
+
+pkgname=intellij-idea-community-edition-no-jre
+_appname=jetbrains-idea-ce
+pkgver=2018.1.2
+_buildver=181.4668.68
+pkgrel=1
+pkgdesc="Intellij Idea Community Edition without bundled JRE"
+arch=('any')
+options=(!strip)
+url="http://www.jetbrains.com/idea/"
+license=("Apache2")
+depends=("giflib" "libxtst" "java-environment")
+provides=("$_appname")
+conflicts=("$_appname")
+source=("https://download.jetbrains.com/idea/ideaIC-$pkgver-no-jdk.tar.gz"
+ "$_appname.desktop")
+md5sums=('752568aae86e97470d01a5aaab5d3521'
+ '9e5798fd87d09fa8f2f24721b6af4d5f')
+
+package() {
+ install -d "$pkgdir"/{opt/$_appname,usr/bin}
+ mv idea-IC-${_buildver}/* "$pkgdir"/opt/$_appname
+
+ # https://youtrack.jetbrains.com/issue/IDEA-185828
+ chmod +x "$pkgdir"/opt/$_appname/plugins/maven/lib/maven3/bin/mvn
+
+ ln -s /opt/$_appname/bin/idea.sh "$pkgdir"/usr/bin/$_appname
+ install -D -m644 "$srcdir"/jetbrains-idea-ce.desktop "$pkgdir"/usr/share/applications/jetbrains-idea-ce.desktop
+ install -D -m644 "$pkgdir"/opt/$_appname/bin/idea.png "$pkgdir"/usr/share/pixmaps/"$_appname".png
+
+ # workaround FS#40934
+ sed -i 's|lcd|on|' "$pkgdir"/opt/$_appname/bin/*.vmoptions
+}
diff --git a/jetbrains-idea-ce.desktop b/jetbrains-idea-ce.desktop
new file mode 100644
index 000000000000..5e8bf7c33fb9
--- /dev/null
+++ b/jetbrains-idea-ce.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Name=IntelliJ IDEA Community
+Comment=Capable and ergonomic Java IDE
+Exec=jetbrains-idea-ce %f
+Icon=jetbrains-idea-ce
+Categories=Development;IDE;
+Terminal=false
+StartupNotify=true
+StartupWMClass=jetbrains-idea-ce