summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoriboyperson2019-04-30 22:29:20 -0700
committeriboyperson2019-04-30 22:29:20 -0700
commitbc6407280334949c6b3e4c6bd1afd77ad06276d4 (patch)
tree734ffd6f38060e563b655f0cd9562f838da7425b
parent8066fb12202e9ebbc9f0d7eae8fd59bb5215c31b (diff)
downloadaur-bc6407280334949c6b3e4c6bd1afd77ad06276d4.tar.gz
updpkg: 2019.1.1-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--jetbrains-idea-ce.desktop2
3 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83c8ce33f766..b66ebbf10295 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = intellij-idea-community-edition-no-jre
pkgdesc = Intellij Idea Community Edition without bundled JRE
- pkgver = 2019.1
+ pkgver = 2019.1.1
pkgrel = 1
url = http://www.jetbrains.com/idea/
arch = any
@@ -14,10 +14,10 @@ pkgbase = intellij-idea-community-edition-no-jre
depends = libdbusmenu-glib
provides = jetbrains-idea-ce
conflicts = jetbrains-idea-ce
- source = https://download.jetbrains.com/idea/ideaIC-2019.1-no-jbr.tar.gz
+ source = https://download.jetbrains.com/idea/ideaIC-2019.1.1-no-jbr.tar.gz
source = jetbrains-idea-ce.desktop
- md5sums = 1ecbae5afcbb3d3a04d5203d23b33ec6
- md5sums = 56d945e72cc22162d5be26af027999dd
+ md5sums = f918759dfb696319f5a01160db9a7ace
+ md5sums = 8255a0c131e7bd57c1f5c9886e1c064d
pkgname = intellij-idea-community-edition-no-jre
diff --git a/PKGBUILD b/PKGBUILD
index b1489ddd8c8b..2a96b4e321dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=intellij-idea-community-edition-no-jre
_appname=jetbrains-idea-ce
-pkgver=2019.1
-_buildver=191.6183.87
+pkgver=2019.1.1
+_buildver=191.6707.61
pkgrel=1
pkgdesc="Intellij Idea Community Edition without bundled JRE"
arch=('any')
@@ -14,8 +14,8 @@ provides=("$_appname")
conflicts=("$_appname")
source=("https://download.jetbrains.com/idea/ideaIC-$pkgver-no-jbr.tar.gz"
"$_appname.desktop")
-md5sums=('1ecbae5afcbb3d3a04d5203d23b33ec6'
- '56d945e72cc22162d5be26af027999dd')
+md5sums=('f918759dfb696319f5a01160db9a7ace'
+ '8255a0c131e7bd57c1f5c9886e1c064d')
package() {
cd idea-IC-"$_buildver"
@@ -24,10 +24,11 @@ package() {
sed -i 's/lcd/on/' bin/*.vmoptions
install -dm 755 "$pkgdir"/usr/bin
- install -dm 755 "$pkgdir"/usr/share/{licenses,pixmaps,"$_appname"}
+ install -dm 755 "$pkgdir"/usr/share/{licenses,pixmaps,"$_appname",icons/hicolor/scalable/apps}
cp -dr --no-preserve='ownership' bin lib plugins redist "$pkgdir"/usr/share/"$_appname/"
cp -dr --no-preserve='ownership' license "$pkgdir"/usr/share/licenses/"$_appname"
ln -s /usr/share/"$_appname"/bin/idea.png "$pkgdir"/usr/share/pixmaps/"$_appname".png
+ ln -s /usr/share/idea/bin/idea.svg "${pkgdir}"/usr/share/icons/hicolor/scalable/apps/"$_appname".svg
install -Dm 644 ../"$_appname".desktop -t "$pkgdir"/usr/share/applications/
ln -s /usr/share/"$_appname"/bin/idea.sh "$pkgdir"/usr/bin/idea-ce
}
diff --git a/jetbrains-idea-ce.desktop b/jetbrains-idea-ce.desktop
index 30265860f3c0..635deec26ed1 100644
--- a/jetbrains-idea-ce.desktop
+++ b/jetbrains-idea-ce.desktop
@@ -1,4 +1,5 @@
[Desktop Entry]
+Version=1.0
Type=Application
Name=IntelliJ IDEA Community
Comment=Capable and ergonomic Java IDE
@@ -8,3 +9,4 @@ Categories=Development;IDE;
Terminal=false
StartupNotify=true
StartupWMClass=jetbrains-idea-ce
+Categories=Development;IDE;Java; \ No newline at end of file