summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD. Can Celasun2017-08-27 17:29:29 +0200
committerD. Can Celasun2017-08-27 17:29:29 +0200
commit64e2edf8f58893124a4021509d99c947592130a3 (patch)
treec397979573f44595f95ac140749b1618c281cd0b
parent89b6beed41d7ec21535542117768ac7701e46b03 (diff)
downloadaur-64e2edf8f58893124a4021509d99c947592130a3.tar.gz
Adjust dependencies
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD6
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01d48372d62e..d08c4828cb67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
# Generated by mksrcinfo v8
-# Wed Aug 16 19:12:43 UTC 2017
+# Sun Aug 27 15:29:14 UTC 2017
pkgbase = intellij-idea-ultimate-edition
pkgdesc = An intelligent IDE for Java, Groovy and other programming languages with advanced refactoring features intensely focused on developer productivity.
pkgver = 2017.2.2
- pkgrel = 2
+ pkgrel = 3
url = https://www.jetbrains.com/idea/
arch = any
license = Commercial
makedepends = rsync
- depends = java-environment
- depends = giflib
- depends = libxtst
options = !strip
source = https://download.jetbrains.com/idea/ideaIU-2017.2.2.tar.gz
source = jetbrains-idea.desktop
@@ -18,6 +15,10 @@ pkgbase = intellij-idea-ultimate-edition
sha256sums = 83af2ba8f9f14275a6684e79d6d4bd9b48cd852c047dacfc81324588fa2ff92b
pkgname = intellij-idea-ultimate-edition
+ depends = giflib
+ depends = libxtst
+ optdepends = intellij-idea-ultimate-edition-jre: JetBrains custom JRE (Recommended)
+ optdepends = java-environment: Required if intellij-idea-ultimate-edition-jre is not installed
backup = usr/share/intellij-idea-ultimate-edition/bin/idea.vmoptions
backup = usr/share/intellij-idea-ultimate-edition/bin/idea64.vmoptions
backup = usr/share/intellij-idea-ultimate-edition/bin/idea.properties
diff --git a/PKGBUILD b/PKGBUILD
index 5149d0007ce9..b1d40d5f15fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,11 @@ pkgbase=intellij-idea-ultimate-edition
pkgname=(intellij-idea-ultimate-edition intellij-idea-ultimate-edition-jre)
pkgver=2017.2.2
_buildver=172.3757.52
-pkgrel=2
+pkgrel=3
arch=('any')
pkgdesc="An intelligent IDE for Java, Groovy and other programming languages with advanced refactoring features intensely focused on developer productivity."
url="https://www.jetbrains.com/idea/"
license=('Commercial')
-depends=('java-environment' 'giflib' 'libxtst')
makedepends=('rsync')
options=(!strip)
source=(https://download.jetbrains.com/idea/ideaIU-$pkgver.tar.gz \
@@ -19,6 +18,9 @@ sha256sums=('b5f33894abbf31786a17779bc11bfbe05f46cbbcd516fc2d48590411c44be95c'
'83af2ba8f9f14275a6684e79d6d4bd9b48cd852c047dacfc81324588fa2ff92b')
package_intellij-idea-ultimate-edition() {
backup=("usr/share/${pkgname}/bin/idea.vmoptions" "usr/share/${pkgname}/bin/idea64.vmoptions" "usr/share/${pkgname}/bin/idea.properties")
+ depends=('giflib' 'libxtst')
+ optdepends=('intellij-idea-ultimate-edition-jre: JetBrains custom JRE (Recommended)' 'java-environment: Required if intellij-idea-ultimate-edition-jre is not installed')
+
cd "$srcdir"
install -d -m755 "${pkgdir}"/usr/{bin,share}