summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-30 10:52:49 +0800
committerzxp198210052023-08-30 10:52:49 +0800
commitc5a932a2900d77244ed6bf8b255e3fa4908ba68f (patch)
tree034c9b95fc53cc01036dfc0fd51611c6ae93d04c
downloadaur-c5a932a2900d77244ed6bf8b255e3fa4908ba68f.tar.gz
update to 2.13.1
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD33
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e5210870337
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = interactive-data-editor-bin
+ pkgdesc = A Software to interactively edit data in a graphical manner
+ pkgver = 2.13.1
+ pkgrel = 1
+ url = https://koushikphy.github.io/Interactive_Data_Editor/
+ arch = x86_64
+ license = MIT
+ depends = gtk3
+ depends = gcc-libs
+ depends = expat
+ depends = libxcb
+ depends = nspr
+ depends = libxext
+ depends = gdk-pixbuf2
+ depends = libxfixes
+ depends = pango
+ depends = dbus
+ depends = libxrandr
+ depends = nss
+ depends = at-spi2-core
+ depends = libxcomposite
+ depends = glib2
+ depends = libxkbcommon
+ depends = mesa
+ depends = cairo
+ depends = libxdamage
+ depends = libdrm
+ depends = hicolor-icon-theme
+ depends = libx11
+ depends = alsa-lib
+ depends = libcups
+ depends = glibc
+ provides = interactive-data-editor=2.13.1
+ conflicts = interactive-data-editor
+ source = interactive-data-editor-2.13.1.deb::https://github.com/Koushikphy/Interactive_Data_Editor/releases/download/v2.13.1/interactive-data-editor_2.13.1_amd64.deb
+ source = LICENSE::https://raw.githubusercontent.com/Koushikphy/Interactive_Data_Editor/master/LICENSE
+ sha256sums = 573c64a1f7105d317f1a4c007c0d9c53499ed1609f66bc5420c15cdfa77a0b1b
+ sha256sums = d728fec9e20c7c6b1528b62e2525c7f98d2f99061e5b8e3bbd33d27f27271265
+
+pkgname = interactive-data-editor-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d738fea9e2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=interactive-data-editor-bin
+_pkgname="Interactive Data Editor"
+pkgver=2.13.1
+pkgrel=1
+pkgdesc="A Software to interactively edit data in a graphical manner"
+arch=('x86_64')
+url="https://koushikphy.github.io/Interactive_Data_Editor/"
+_githuburl="https://github.com/Koushikphy/Interactive_Data_Editor"
+license=('MIT')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=('gtk3' 'gcc-libs' 'expat' 'libxcb' 'nspr' 'libxext' 'gdk-pixbuf2' 'libxfixes' 'pango' 'dbus' 'libxrandr' 'nss' 'at-spi2-core' \
+ 'libxcomposite' 'glib2' 'libxkbcommon' 'mesa' 'cairo' 'libxdamage' 'libdrm' 'hicolor-icon-theme' 'libx11' 'alsa-lib' 'libcups' 'glibc')
+source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
+ "LICENSE::https://raw.githubusercontent.com/Koushikphy/Interactive_Data_Editor/master/LICENSE")
+sha256sums=('573c64a1f7105d317f1a4c007c0d9c53499ed1609f66bc5420c15cdfa77a0b1b'
+ 'd728fec9e20c7c6b1528b62e2525c7f98d2f99061e5b8e3bbd33d27f27271265')
+prepare() {
+ bsdtar -xf "${srcdir}/data.tar.xz"
+ sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\" %U|${pkgname%-bin} %U --no-sandbox|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+}
+package() {
+ install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/bin}
+ cp -r "${srcdir}/opt/${_pkgname}/"* "${pkgdir}/opt/${pkgname%-bin}"
+ ln -sf "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512;do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
+ done
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file