diff options
author | zxp19821005 | 2024-03-05 08:54:56 +0800 |
---|---|---|
committer | zxp19821005 | 2024-03-05 08:54:56 +0800 |
commit | b433329079225ebd78f8657078492a44839e2bca (patch) | |
tree | 888d07a0da90bdded1d4a4a43941ac38db172c25 | |
parent | 122b4406a25e2c3be3444ab8b2a83122dbeaeae9 (diff) | |
download | aur-b433329079225ebd78f8657078492a44839e2bca.tar.gz |
fix errors
-rw-r--r-- | .SRCINFO | 9 | ||||
-rw-r--r-- | PKGBUILD | 9 | ||||
-rw-r--r-- | interastral-peace-chat.sh | 3 |
3 files changed, 8 insertions, 13 deletions
@@ -1,15 +1,12 @@ pkgbase = interastral-peace-chat-bin pkgdesc = Interastral Peace Chat (HSR messaging app) pkgver = 1.0.0 - pkgrel = 6 + pkgrel = 7 url = https://github.com/niizam/ipc arch = x86_64 license = MIT - makedepends = squashfuse + makedepends = fuse2 depends = electron24 - depends = dbus-glib - depends = libdbusmenu-glib - depends = gtk2 provides = interastral-peace-chat=1.0.0 conflicts = interastral-peace-chat source = interastral-peace-chat-1.0.0.AppImage::https://github.com/niizam/ipc/releases/download/v1.0.0/Interastral.Peace.Chat-linux-x64-1.0.0.AppImage @@ -17,6 +14,6 @@ pkgbase = interastral-peace-chat-bin source = interastral-peace-chat.sh sha256sums = 4e190977093c308f8122a716e005814d72b28a832dce341c1026f52c6ec370f5 sha256sums = 4a0102513b658872c91f6e2a2d8244aaaab86c8686bc572c169b386d511c6975 - sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014 + sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe pkgname = interastral-peace-chat-bin @@ -4,7 +4,7 @@ _pkgname=ipc _appname=Interastral.Peace.Chat pkgver=1.0.0 _electronversion=24 -pkgrel=6 +pkgrel=7 pkgdesc="Interastral Peace Chat (HSR messaging app)" arch=('x86_64') url="https://github.com/niizam/ipc" @@ -13,12 +13,9 @@ provides=("${pkgname%-bin}=${pkgver}") conflicts=("${pkgname%-bin}") depends=( "electron${_electronversion}" - 'dbus-glib' - 'libdbusmenu-glib' - 'gtk2' ) makedepends=( - 'squashfuse' + 'fuse2' ) source=( "${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${_appname}-linux-x64-${pkgver}.AppImage" @@ -27,7 +24,7 @@ source=( ) sha256sums=('4e190977093c308f8122a716e005814d72b28a832dce341c1026f52c6ec370f5' '4a0102513b658872c91f6e2a2d8244aaaab86c8686bc572c169b386d511c6975' - '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014') + '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe') build() { sed -e "s|@electronversion@|${_electronversion}|g" \ -e "s|@appname@|${pkgname%-bin}|g" \ diff --git a/interastral-peace-chat.sh b/interastral-peace-chat.sh index f9ced1432cfc..86cb3dc6a9bf 100644 --- a/interastral-peace-chat.sh +++ b/interastral-peace-chat.sh @@ -1,10 +1,11 @@ -#!/bin/sh +#!/bin/bash set -e _APPDIR="/usr/lib/@appname@" _RUNNAME="${_APPDIR}/@runname@" export PATH="${_APPDIR}:${PATH}" export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}" export ELECTRON_IS_DEV=0 +export ELECTRON_FORCE_IS_PACKAGED=true export NODE_ENV=production cd "${_APPDIR}" if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then |