summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Lopes2019-01-28 03:16:50 -0200
committerFrancisco Lopes2019-01-28 03:16:50 -0200
commitfeb5d6b3ad6876a95b6ed39857878eb45c70f123 (patch)
tree2bc249169b0212039148ce60764bd07ab0076335
parenta2703511a8db774ae148d413790c4e78cda0a155 (diff)
downloadaur-feb5d6b3ad6876a95b6ed39857878eb45c70f123.tar.gz
Fix out of source cmake generation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3180cfb35f1b..60c515a81e76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = interception-caps2esc
pkgdesc = caps2esc: transforming the most useless key ever in the most useful one
pkgver = 0.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/interception/linux/plugins/caps2esc
arch = x86_64
license = MIT
@@ -9,7 +9,7 @@ pkgbase = interception-caps2esc
makedepends = gcc
depends = interception-tools
conflicts = caps2esc
- source = https://gitlab.com/interception/linux/plugins/caps2esc/repository/archive.tar.gz?ref=v0.1.3
+ source = interception-caps2esc.tar.gz::https://gitlab.com/interception/linux/plugins/caps2esc/repository/archive.tar.gz?ref=v0.1.3
md5sums = 014e1b3fcd7fd889aab876f22d550eb8
pkgname = interception-caps2esc
diff --git a/PKGBUILD b/PKGBUILD
index f132eb83f23a..9befd0841eba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Francisco Lopes <francisco@oblita.com>
pkgname=interception-caps2esc
pkgver=0.1.3
-pkgrel=1
+pkgrel=2
pkgdesc='caps2esc: transforming the most useless key ever in the most useful one'
arch=('x86_64')
license=('MIT')
@@ -9,20 +9,17 @@ url='https://gitlab.com/interception/linux/plugins/caps2esc'
depends=('interception-tools')
makedepends=('cmake' 'gcc')
conflicts=('caps2esc')
-source=("https://gitlab.com/interception/linux/plugins/caps2esc/repository/archive.tar.gz?ref=v${pkgver}")
+source=("$pkgname.tar.gz::https://gitlab.com/interception/linux/plugins/caps2esc/repository/archive.tar.gz?ref=v${pkgver}")
md5sums=('014e1b3fcd7fd889aab876f22d550eb8')
build() {
cd ${srcdir}/caps2esc-v${pkgver}-*
- cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" -DCMAKE_BUILD_TYPE=Release
- make
+ cmake -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
}
package() {
- cd ${srcdir}/caps2esc-v${pkgver}-*
-
- mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m 444 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd ${srcdir}/caps2esc-v${pkgver}-*/build
- make install
+ make DESTDIR="$pkgdir/" install
}