summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Courtis2020-05-26 14:29:34 +1000
committerAlexander Courtis2020-05-26 14:29:34 +1000
commit362d216e815e47e59974e3d68dffc9be08d6a71b (patch)
tree3768430ec8f9f1dc70a9dad7386067f451681790
downloadaur-362d216e815e47e59974e3d68dffc9be08d6a71b.tar.gz
first release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92f4f0878e74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = interception-dual-function-keys
+ pkgdesc = Dual function keys: tap for one key, hold for another.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://gitlab.com/interception/linux/plugins/dual-function-keys/
+ arch = x86_64
+ license = MIT
+ depends = interception-tools
+ source = interception-dual-function-keys-1.0.0.tar.gz::https://gitlab.com/interception/linux/plugins/dual-function-keys/repository/archive.tar.gz?ref=1.0.0
+ md5sums = d47da2941f18e5b0d3d4e4492ae08648
+
+pkgname = interception-dual-function-keys
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f81f0c00058f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alexander Courtis <alex@courtis.org>
+pkgname=interception-dual-function-keys
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Dual function keys: tap for one key, hold for another."
+arch=('x86_64')
+url="https://gitlab.com/interception/linux/plugins/dual-function-keys/"
+license=('MIT')
+depends=('interception-tools')
+source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/interception/linux/plugins/dual-function-keys/repository/archive.tar.gz?ref=${pkgver}")
+md5sums=('d47da2941f18e5b0d3d4e4492ae08648')
+
+build() {
+ cd $srcdir/dual-function-keys-$pkgver-*
+
+ make
+}
+
+package() {
+ cd $srcdir/dual-function-keys-$pkgver-*
+
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}