summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Lopes2021-05-10 16:28:55 -0300
committerFrancisco Lopes2021-05-10 16:28:55 -0300
commit343d9476ab211cf459534ff4705188261a4725b2 (patch)
tree84436ef615d417ee056539281ca04f38784104d5
parent36b287bf2fc7cf0d9f783b6d0e7b58a72dae2250 (diff)
downloadaur-343d9476ab211cf459534ff4705188261a4725b2.tar.gz
Fix due to change in GitLab asset's urls
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 696dac2c08ea..fa973c986433 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = interception-uswitch
pkgdesc = uswitch: an Interception Tools tool to redirect stdin to a muxer if logged user matches
pkgver = 0.1.1
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/interception/linux/plugins/uswitch
arch = x86_64
license = MIT
@@ -10,8 +10,8 @@ pkgbase = interception-uswitch
makedepends = gcc
depends = interception-tools
depends = glibc
- source = interception-uswitch.tar.gz::https://gitlab.com/interception/linux/plugins/uswitch/repository/archive.tar.gz?ref=v0.1.1
- sha256sums = 66659db28aeae1156541f9ac33f7a0d3fc78b0da35b30e607401c263a4834b10
+ source = https://gitlab.com/interception/linux/plugins/uswitch/-/archive/v0.1.1/uswitch-v0.1.1.tar.gz
+ sha256sums = 3e4cc6dfc85afb929c31051ebba19f080210a791cebd16607480bc8a5a207ba1
pkgname = interception-uswitch
diff --git a/PKGBUILD b/PKGBUILD
index 4ce10276dbde..c90e4ccbccad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Francisco Lopes <francisco+interception@nosubstance.me>
pkgname=interception-uswitch
pkgver=0.1.1
-pkgrel=2
+pkgrel=3
pkgdesc='uswitch: an Interception Tools tool to redirect stdin to a muxer if logged user matches'
arch=('x86_64')
license=('MIT')
url='https://gitlab.com/interception/linux/plugins/uswitch'
depends=('interception-tools' 'glibc')
makedepends=('boost' 'cmake' 'gcc')
-source=("$pkgname.tar.gz::https://gitlab.com/interception/linux/plugins/uswitch/repository/archive.tar.gz?ref=v${pkgver}")
-sha256sums=('66659db28aeae1156541f9ac33f7a0d3fc78b0da35b30e607401c263a4834b10')
+source=("https://gitlab.com/interception/linux/plugins/uswitch/-/archive/v${pkgver}/uswitch-v${pkgver}.tar.gz")
+sha256sums=('3e4cc6dfc85afb929c31051ebba19f080210a791cebd16607480bc8a5a207ba1')
build() {
- cd ${srcdir}/uswitch-v${pkgver}-*
+ cd ${srcdir}/uswitch-v${pkgver}
cmake -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
cmake --build build
}
package() {
- cd ${srcdir}/uswitch-v${pkgver}-*/build
+ cd ${srcdir}/uswitch-v${pkgver}/build
make DESTDIR="$pkgdir/" install