summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Lopes2021-01-12 16:57:38 -0300
committerFrancisco Lopes2021-01-12 16:57:38 -0300
commit961c200707efd94806693e454a9e707e6d2ef007 (patch)
tree2643df9615d85aeaf3bcb679045ff6e23d1cd85a
downloadaur-961c200707efd94806693e454a9e707e6d2ef007.tar.gz
0.1.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd8aa5c1e47e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = interception-uswitch
+ pkgdesc = uswitch: an Interception Tools tool to redirect stdin to a muxer if logged user matches
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://gitlab.com/interception/linux/plugins/uswitch
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = cmake
+ makedepends = gcc
+ depends = interception-tools
+ depends = glibc
+ source = interception-uswitch.tar.gz::https://gitlab.com/interception/linux/plugins/uswitch/repository/archive.tar.gz?ref=v0.1.0
+ sha256sums = 5176239cef3fb536ca58070231866bbdd3515acb47e91343f122dcb22c92d008
+
+pkgname = interception-uswitch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d05b111b5e1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Francisco Lopes <francisco+interception@nosubstance.me>
+pkgname=interception-uswitch
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='uswitch: an Interception Tools tool to redirect stdin to a muxer if logged user matches'
+arch=('x86_64')
+license=('MIT')
+url='https://gitlab.com/interception/linux/plugins/uswitch'
+depends=('interception-tools' 'glibc')
+makedepends=('boost' 'cmake' 'gcc')
+source=("$pkgname.tar.gz::https://gitlab.com/interception/linux/plugins/uswitch/repository/archive.tar.gz?ref=v${pkgver}")
+sha256sums=('5176239cef3fb536ca58070231866bbdd3515acb47e91343f122dcb22c92d008')
+
+build() {
+ cd ${srcdir}/uswitch-v${pkgver}-*
+ cmake -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
+}
+
+package() {
+ cd ${srcdir}/uswitch-v${pkgver}-*/build
+
+ make DESTDIR="$pkgdir/" install
+}