summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Lopes2021-01-11 13:54:19 -0300
committerFrancisco Lopes2021-01-11 13:54:19 -0300
commit4c48f31229d73044e14941f22de92d584544e748 (patch)
tree56d35dd70f6316e3767a75e3c204519e1c99dbef
downloadaur-4c48f31229d73044e14941f22de92d584544e748.tar.gz
0.1.1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac89a14debe8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = interception-xswitch
+ pkgdesc = xswitch: an Interception Tools tool to redirect stdin to a muxer if a X window matches
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://gitlab.com/interception/linux/plugins/xswitch
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = cmake
+ makedepends = gcc
+ depends = interception-tools
+ depends = glibc
+ depends = libx11
+ depends = libxmu
+ source = interception-xswitch.tar.gz::https://gitlab.com/interception/linux/plugins/xswitch/repository/archive.tar.gz?ref=v0.1.1
+ sha256sums = 8bb49502179b6433e43fcc7051f5aad52695cee70b5bdab59818719d64682690
+
+pkgname = interception-xswitch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01361861b355
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Francisco Lopes <francisco+interception@nosubstance.me>
+pkgname=interception-xswitch
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='xswitch: an Interception Tools tool to redirect stdin to a muxer if a X window matches'
+arch=('x86_64')
+license=('MIT')
+url='https://gitlab.com/interception/linux/plugins/xswitch'
+depends=('interception-tools' 'glibc' 'libx11' 'libxmu')
+makedepends=('boost' 'cmake' 'gcc')
+source=("$pkgname.tar.gz::https://gitlab.com/interception/linux/plugins/xswitch/repository/archive.tar.gz?ref=v${pkgver}")
+sha256sums=('8bb49502179b6433e43fcc7051f5aad52695cee70b5bdab59818719d64682690')
+
+build() {
+ cd ${srcdir}/xswitch-v${pkgver}-*
+ cmake -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
+}
+
+package() {
+ cd ${srcdir}/xswitch-v${pkgver}-*/build
+
+ make DESTDIR="$pkgdir/" install
+}