summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRon Asimi2018-11-27 15:17:47 -0500
committerRon Asimi2018-11-27 15:17:47 -0500
commitc0bf442e6e9d539ccd79a16bf9e5cbd7eee550ad (patch)
tree1d93037d6c3e9f0ee95aeed4aabc7ba46008e935
downloadaur-c0bf442e6e9d539ccd79a16bf9e5cbd7eee550ad.tar.gz
initial commit - v3.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96875e19e99a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = interui-otf
+ pkgdesc = Inter UI is a typeface specially designed for user interfaces with focus on high legibility of small-to-medium sized text on computer screens.
+ pkgver = 3.1
+ pkgrel = 1
+ url = https://rsms.me/inter/
+ arch = any
+ license = custom:SIL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://github.com/rsms/inter/releases/download/v3.1/Inter-UI-3.1.zip
+ source = https://raw.githubusercontent.com/rsms/inter/master/LICENSE.txt
+ sha256sums = 07e25f3e9a1a156db36a383213c0b753fb3099c55ee84f7b0eeddbd77a7c8eca
+ sha256sums = 40cc017183821b3163b4ab30c186019f05573323fdacb1cd9563c97098f8183c
+
+pkgname = interui-otf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9a3c6abc63f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Ron Asimi <ron.asimi@gmail.com>
+pkgname=interui-otf
+pkgver=3.1
+pkgrel=1
+pkgdesc='Inter UI is a typeface specially designed for user interfaces with focus on high legibility of small-to-medium sized text on computer screens.'
+arch=('any')
+url='https://rsms.me/inter/'
+license=('custom:SIL')
+depends=('fontconfig' 'xorg-font-utils')
+source=("https://github.com/rsms/inter/releases/download/v${pkgver}/Inter-UI-${pkgver}.zip"
+ "https://raw.githubusercontent.com/rsms/inter/master/LICENSE.txt")
+sha256sums=('07e25f3e9a1a156db36a383213c0b753fb3099c55ee84f7b0eeddbd77a7c8eca'
+ '40cc017183821b3163b4ab30c186019f05573323fdacb1cd9563c97098f8183c')
+package() {
+ install -d ${pkgdir}/usr/share/fonts/OTF/
+ install -m644 "${srcdir}/Inter UI (OTF)/"*.otf ${pkgdir}/usr/share/fonts/OTF/
+ install -D -m644 ${srcdir}/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+}