summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2020-11-21 16:30:13 -0800
committermutantmonkey2020-11-21 16:30:13 -0800
commit7ab17def040addddc813333b10f018eecbca5174 (patch)
treec6e41c91330a76c972829fd3cde0f11c4ab80534
parent681cbc62547885c21ffc3a0aa953288f88aa45e0 (diff)
downloadaur-7ab17def040addddc813333b10f018eecbca5174.tar.gz
upgpkg: intiface-desktop 19.0.0-3
Use install to install app.asar with correct file mode rather than relying on an appropriate umask.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f35c212e72d..1df65c1d576d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = intiface-desktop
pkgdesc = Open-source, cross-platform application that acts as a hub for sex hardware access
pkgver = 19.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://intiface.com/desktop/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e4a6769dda8a..8a1a896f8fd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=intiface-desktop
pkgver=19.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Open-source, cross-platform application that acts as a hub for sex hardware access"
depends=('electron')
makedepends=('npm' 'yarn' 'git' 'trash-cli' 'typescript')
@@ -37,9 +37,10 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
- install -dm755 "${pkgdir}/usr/lib/${pkgname}"
- cp -r packages/intiface/dist_electron/linux-unpacked/resources \
- "${pkgdir}/usr/lib/${pkgname}"
+ install -dm755 "${pkgdir}/usr/lib/${pkgname}/resources"
+ install -m644 \
+ packages/intiface/dist_electron/linux-unpacked/resources/app.asar \
+ "${pkgdir}/usr/lib/${pkgname}/resources/app.asar"
install -dm755 "${pkgdir}/usr/bin"
install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"