summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2021-06-12 00:59:03 -0700
committermutantmonkey2021-06-12 00:59:03 -0700
commit9cd5329fd07d58f8fa08fd0ee62a7700ba173679 (patch)
treeddb9a9a5e5f71e40c32eca591ac7ba09e0b32e9c
parent394a2d198dd09662f7dc29b77b3448b1cd75c2e9 (diff)
downloadaur-9cd5329fd07d58f8fa08fd0ee62a7700ba173679.tar.gz
upgpkg: intiface-desktop 21.0.0-1
upstream release
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
-rw-r--r--core_isonline_fix.patch13
3 files changed, 12 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 200b3801fc9f..e7117b651e69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = intiface-desktop
pkgdesc = Open-source, cross-platform application that acts as a hub for sex hardware access
- pkgver = 20.0.0
- pkgrel = 2
+ pkgver = 21.0.0
+ pkgrel = 1
url = https://intiface.com/desktop/
arch = i686
arch = x86_64
@@ -12,14 +12,11 @@ pkgbase = intiface-desktop
makedepends = trash-cli
makedepends = typescript
depends = electron
- source = intiface-desktop-20.0.0.tar.gz::https://github.com/intiface/intiface-desktop/archive/v20.0.0.tar.gz
+ source = intiface-desktop-21.0.0.tar.gz::https://github.com/intiface/intiface-desktop/archive/v21.0.0.tar.gz
source = intiface-desktop.sh
source = intiface-desktop.desktop
- source = core_isonline_fix.patch
- sha256sums = 9402de0e8aa9b969ae90538ef96e7df3b6252dec73f14f0c2105c5381976b6d2
+ sha256sums = e39e65b302215ee58ebd13a0a234049ca6fb0bf7d73b817ba64ca9089cfaea2f
sha256sums = 2f7d3350631fda4da8f03938eb06b0b6d3ed571c9975906b7863298f75e4c73f
sha256sums = ece9fd45978dae583a9c572f3e64f8234350d5e53f9c1ae2da503c53b3ecff64
- sha256sums = 0060f45c1036f19955940f843d52c820a50cb9f362e3ad91ab0eb13a8d6e525c
pkgname = intiface-desktop
-
diff --git a/PKGBUILD b/PKGBUILD
index c3909c856a8d..d353c1c44ae2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: mutantmonkey <aur@mutantmonkey.mx>
pkgname=intiface-desktop
-pkgver=20.0.0
-pkgrel=2
+pkgver=21.0.0
+pkgrel=1
pkgdesc="Open-source, cross-platform application that acts as a hub for sex hardware access"
depends=('electron')
makedepends=('npm' 'yarn' 'git' 'trash-cli' 'typescript')
@@ -11,17 +11,10 @@ url="https://intiface.com/desktop/"
license=('BSD')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/intiface/intiface-desktop/archive/v${pkgver}.tar.gz"
'intiface-desktop.sh'
- 'intiface-desktop.desktop'
- 'core_isonline_fix.patch')
-sha256sums=('9402de0e8aa9b969ae90538ef96e7df3b6252dec73f14f0c2105c5381976b6d2'
+ 'intiface-desktop.desktop')
+sha256sums=('e39e65b302215ee58ebd13a0a234049ca6fb0bf7d73b817ba64ca9089cfaea2f'
'2f7d3350631fda4da8f03938eb06b0b6d3ed571c9975906b7863298f75e4c73f'
- 'ece9fd45978dae583a9c572f3e64f8234350d5e53f9c1ae2da503c53b3ecff64'
- '0060f45c1036f19955940f843d52c820a50cb9f362e3ad91ab0eb13a8d6e525c')
-
-prepare() {
- cd "${pkgname}-${pkgver}"
- patch -p1 -i ../core_isonline_fix.patch
-}
+ 'ece9fd45978dae583a9c572f3e64f8234350d5e53f9c1ae2da503c53b3ecff64')
build() {
cd "${pkgname}-${pkgver}"
@@ -36,6 +29,9 @@ build() {
cd ../core
yarn
yarn build
+ cd ../core-backend
+ yarn
+ yarn build
cd ../intiface
yarn
yarn electron:build --publish never
diff --git a/core_isonline_fix.patch b/core_isonline_fix.patch
deleted file mode 100644
index 504b661110a8..000000000000
--- a/core_isonline_fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/packages/core/src/IntifaceBackendManager.ts b/packages/core/src/IntifaceBackendManager.ts
-index 35346b2..aa36775 100644
---- a/packages/core/src/IntifaceBackendManager.ts
-+++ b/packages/core/src/IntifaceBackendManager.ts
-@@ -9,7 +9,7 @@ import { IntifaceUtils } from "./Utils";
- import { IApplicationUpdater } from "./IApplicationUpdater";
- import { IntifaceBackendLogger } from "./IntifaceBackendLogger";
- import { EventEmitter } from "events";
--import isOnline from "is-online";
-+import * as isOnline from "is-online";
- import { promisify } from "util";
- import * as winston from "winston";
- import * as rimraf from "rimraf";