summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlessandroZanatta2023-03-02 11:42:11 +0100
committerAlessandroZanatta2023-03-02 11:42:11 +0100
commit834047a05fd23ead76420875f9654795975805b6 (patch)
tree7d719381cb347f1869b9775406125ccc798d0a8e
downloadaur-834047a05fd23ead76420875f9654795975805b6.tar.gz
Initial creation of package
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD22
3 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..875d5d6f3821
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = into-cps-application-bin
+ pkgdesc = Frontend of the INTO-CPS Tool Chain
+ pkgver = 4.0.5
+ pkgrel = 1
+ url = https://github.com/INTO-CPS-Association/into-cps-application
+ arch = x86_64
+ license = MIT
+ provides = into-cps-application
+ source = https://github.com/INTO-CPS-Association/INTO-CPS-application/releases/download/v4.0.5/INTO-CPS-application-4.0.5.AppImage
+ sha256sums = 6d7650d4c85289ddb0509271ef5185a046beb1c4a485d778cfa9cee45d7d6f40
+
+pkgname = into-cps-application-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e284139e68fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alessandro Zanatta <alessandro.zanatta.lav@gmail.com>
+pkgname=into-cps-application-bin
+_pkgname=INTO-CPS-application
+pkgver=4.0.5
+pkgrel=1
+pkgdesc="Frontend of the INTO-CPS Tool Chain"
+arch=('x86_64')
+url="https://github.com/INTO-CPS-Association/into-cps-application"
+license=('MIT')
+provides=('into-cps-application')
+source=("https://github.com/INTO-CPS-Association/$_pkgname/releases/download/v$pkgver/$_pkgname-$pkgver.AppImage")
+sha256sums=('6d7650d4c85289ddb0509271ef5185a046beb1c4a485d778cfa9cee45d7d6f40')
+optdepends=()
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname-$pkgver.AppImage" "$pkgdir/opt/$_pkgname/$_pkgname.AppImage"
+
+ # Symlink AppImage
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s "/opt/$_pkgname/$_pkgname.AppImage" "$pkgdir/usr/bin/$_pkgname"
+}
+