summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCôme Chilliet2016-08-04 00:42:09 +0200
committerCôme Chilliet2016-08-04 00:42:09 +0200
commit7ea9ad215b553efc2c78bb76ec87a65ad6cf7a52 (patch)
treebebcb0ddf44dc512d3c50a04ec53db1180255560
downloadaur-7ea9ad215b553efc2c78bb76ec87a65ad6cf7a52.tar.gz
First try. Not working as haskell-sdl packages are not found
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD30
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebe1559d9fe7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Wed Aug 3 22:42:01 UTC 2016
+pkgbase = intricacy
+ pkgdesc = A game of competitive puzzle-design
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = http://mbays.freeshell.org/intricacy
+ arch = i686
+ arch = x86_64
+ license = GPL-3
+ makedepends = ghc
+ depends = haskell-sdl
+ depends = haskell-sdl-gfx
+ depends = haskell-sdl-ttf
+ depends = haskell-network-fancy
+ depends = haskell-cryptohash
+ depends = haskell-mtl
+ depends = haskell-safe
+ depends = haskell-stm
+ depends = haskell-vector
+ options = strip
+ source = http://sdf.org/~mbays/intricacy/intricacy-0.6.2.tar.gz
+ sha256sums = dce6907980d4b3e9eace2e4e5f5192459992a365d12d2c22860ff1afe2ffb5c7
+
+pkgname = intricacy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b84b5c0d891b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Mantainer: MCMic <come@chilliet.eu>
+
+# PKGBUILD options/directives
+pkgname=intricacy
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="A game of competitive puzzle-design"
+url="http://mbays.freeshell.org/intricacy"
+license=("GPL-3")
+arch=('i686' 'x86_64')
+makedepends=('ghc')
+depends=('haskell-sdl' 'haskell-sdl-gfx' 'haskell-sdl-ttf' 'haskell-network-fancy' 'haskell-cryptohash' 'haskell-mtl' 'haskell-safe' 'haskell-stm' 'haskell-vector')
+options=('strip')
+source=("http://sdf.org/~mbays/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=("dce6907980d4b3e9eace2e4e5f5192459992a365d12d2c22860ff1afe2ffb5c7")
+
+# PKGBUILD functions
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ runhaskell Setup configure -O --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ -f-server -fgame -fcurses -fsdl
+ runhaskell Setup build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+}