summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2023-10-10 22:51:36 +0200
committerDan Johansen2023-10-10 22:51:36 +0200
commit2d6dc2fbada98f922824d507af0b9b9201d3373b (patch)
treec0f10698950016378463cbf18ad241848f7ecd42
downloadaur-2d6dc2fbada98f922824d507af0b9b9201d3373b.tar.gz
initial commit
Signed-off-by: Dan Johansen <strit@strits.dk>
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
-rw-r--r--intune-portal-bin.install15
-rw-r--r--os-release6
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87008e1711ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = intune-portal-bin
+ pkgdesc = Enroll devices in Microsoft Azure Endpoint
+ pkgver = 1.2307.12
+ pkgrel = 1
+ url = http://intune.microsoft.com
+ install = intune-portal-bin.install
+ arch = x86_64
+ license = commercial
+ depends = curl
+ depends = at-spi2-core
+ depends = msalsdk-dbusclient
+ depends = gtk3
+ depends = webkit2gtk
+ depends = libsoup
+ depends = gnome-keyring
+ depends = libpwquality
+ depends = libx11
+ depends = sqlite3
+ provides = intune-portal
+ source = https://packages.microsoft.com/ubuntu/22.04/prod/pool/main/i/intune-portal/intune-portal_1.2307.12_amd64.deb
+ sha256sums = e3d68d9182856d91b4874e376be063d30f4f87bd04aa141bbcb2d6ed80e7bc57
+
+pkgname = intune-portal-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c352e05e151
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Dan Johansen <strit@strits.dk>
+
+pkgname=intune-portal-bin
+_pkgname=intune-portal
+pkgver=1.2307.12
+pkgrel=1
+pkgdesc="Enroll devices in Microsoft Azure Endpoint"
+arch=('x86_64')
+url="http://intune.microsoft.com"
+license=('commercial')
+provides=('intune-portal')
+depends=('curl' 'at-spi2-core' 'msalsdk-dbusclient' 'gtk3' 'webkit2gtk' 'libsoup' 'gnome-keyring' 'libpwquality' 'libx11' 'sqlite3')
+install=$pkgname.install
+source=("https://packages.microsoft.com/ubuntu/22.04/prod/pool/main/i/${_pkgname}/${_pkgname}_${pkgver}_amd64.deb")
+sha256sums=('e3d68d9182856d91b4874e376be063d30f4f87bd04aa141bbcb2d6ed80e7bc57')
+
+prepare() {
+ ar x "${_pkgname}_${pkgver}_amd64.deb"
+ tar -xvf data.tar.xz
+}
+
+package() {
+ install -d "$pkgdir"/usr/lib/systemd/{system,user}
+ install -d "$pkgdir"/opt/microsoft/intune/{bin,share}
+ install -d "$pkgdir"/usr/lib/{tmpfiles.d,x86_64-linux-gnu/security}
+ install -Dm644 "$srcdir"/usr/share/pam-configs/intune -t "$pkgdir"/etc/pam.d/
+ install -Dm644 "$srcdir"/usr/lib/x86_64-linux-gnu/security/pam_intune.so -t "$pkgdir"/usr/lib/x86_64-linux-gnu/security/
+ install -Dm644 "$srcdir"/usr/lib/tmpfiles.d/intune.conf -t "$pkgdir"/usr/lib/tmpfiles.d/
+ install -Dm644 "$srcdir"/usr/share/applications/intune-portal.desktop -t "$pkgdir"/usr/share/applications/
+ install -Dm644 "$srcdir"/usr/share/icons/hicolor/48x48/apps/intune.png -t "$pkgdir"/usr/share/icons/hicolor/48x48/apps/
+ install -Dm644 "$srcdir"/usr/share/polkit-1/actions/com.microsoft.intune.policy -t "$pkgdir"/usr/share/polkit-1/actions/
+ install -Dm644 "$srcdir"/usr/share/doc/intune-portal/copyright -t "$pkgdir"/usr/share/doc/intune-portal/
+ install -Dm644 "$srcdir"/lib/systemd/system/* "$pkgdir"/usr/lib/systemd/system/
+ install -Dm644 "$srcdir"/lib/systemd/user/* "$pkgdir"/usr/lib/systemd/user/
+ install -Dm755 "$srcdir"/opt/microsoft/intune/bin/* "$pkgdir"/opt/microsoft/intune/bin/
+ install -Dm644 "$srcdir"/os-release -t "$pkgdir"/opt/microsoft/intune/share/
+ cp -r "$srcdir"/opt/microsoft/intune/share/* "$pkgdir"/opt/microsoft/intune/share/
+}
diff --git a/intune-portal-bin.install b/intune-portal-bin.install
new file mode 100644
index 000000000000..e5f51129ed93
--- /dev/null
+++ b/intune-portal-bin.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo "Before you can enroll your device, you need to enable the service and timer and then reboot:"
+ echo "'sudo systemctl enable intune-daemon.service'"
+ echo "'systemctl --user enable intune-agent.service intune-agent.timer'"
+ echo "Don't forget to reboot after running the above commands!"
+
+ # Replace the os-release file, since Intune currently only supports Ubuntu systems
+ mv /etc/os-release /etc/os-release.bak #backup current link file
+ cp /opt/microsoft/intune/share/os-release /etc/os-release #place Ubuntu based os-release file
+}
+
+post_remove() {
+ # Put back original os-release file
+ mv /etc/os-release.bak /etc/os-release
+}
diff --git a/os-release b/os-release
new file mode 100644
index 000000000000..e483f286df41
--- /dev/null
+++ b/os-release
@@ -0,0 +1,6 @@
+PRETTY_NAME="Ubuntu 22.04.3 LTS"
+NAME="Ubuntu"
+VERSION_ID="22.04"
+VERSION="22.04.3 LTS (Jammy Jellyfish)"
+VERSION_CODENAME=jammy
+ID=ubuntu