summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpetRUShka2015-07-01 17:32:32 +0300
committerpetRUShka2015-07-01 17:32:32 +0300
commit0e137e8f02b66346c7f014be90bd06654d998890 (patch)
treec0c18a8060d242cd9821d02879ba5d31ceb2bee1
downloadaur-0e137e8f02b66346c7f014be90bd06654d998890.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
3 files changed, 59 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..e88441dd7642
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = intuos4-led
+ pkgdesc = Command line tool to set the Wacom Intuos4 tablet’s LED displays
+ pkgver = 0.003
+ pkgrel = 1
+ url = http://braindump.kargulus.de/?p=432
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc
+ makedepends = make
+ depends = libusb
+ depends = imagemagick
+ source = http://braindump.kargulus.de/wp-content/uploads/intuos4-led-0.003.tar.gz
+
+pkgname = intuos4-led
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7019b42036bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = intuos4-led
+ pkgdesc = Command line tool to set the Wacom Intuos4 tablet’s LED displays
+ pkgver = 0.003
+ pkgrel = 1
+ url = http://braindump.kargulus.de/?p=432
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc
+ makedepends = make
+ depends = libusb
+ depends = imagemagick
+ source = http://braindump.kargulus.de/wp-content/uploads/intuos4-led-0.003.tar.gz
+ md5sums = 96bcad7e86472ec1be53b259d9aa200f
+
+pkgname = intuos4-led
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3993f2ce2529
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jason Gerecke <killertofu@gmail.com>
+pkgname=intuos4-led
+pkgver=0.003
+pkgrel=1
+pkgdesc="Command line tool to set the Wacom Intuos4 tablet’s LED displays"
+arch=('i686' 'x86_64')
+url="http://braindump.kargulus.de/?p=432"
+license=('GPL3')
+depends=('libusb' 'imagemagick')
+makedepends=('gcc' 'make')
+source=("http://braindump.kargulus.de/wp-content/uploads/${pkgname}-${pkgver}.tar.gz")
+md5sums=('96bcad7e86472ec1be53b259d9aa200f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/src"
+ sed -i 's/ImageMagick/\0-6/' Makefile
+ MAGICK=$()
+ sed -i "s/\-lMagick++/$(Magick++-config --ldflags)/" Makefile
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/src"
+ install -Dm 755 intuos4-led-check ${pkgdir}/usr/bin/intuos4-led-check
+ install -Dm 755 intuos4-led-config ${pkgdir}/usr/bin/intuos4-led-config
+}