summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Moore2016-02-17 20:44:33 -0600
committerAlan Moore2016-02-17 20:44:33 -0600
commitf831986ece60d711f7bf23233aaea59a030e532c (patch)
tree74883c02a1f64997570124e39a46d431d34c3291
downloadaur-f831986ece60d711f7bf23233aaea59a030e532c.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d68d6e1a3452
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 5.0.0
+# Thu Feb 18 02:44:16 UTC 2016
+pkgbase = invada-studio-plugins
+ pkgdesc = LADSPA audio effect plugins from invada, ported from VST. You probably want the LV2 versions, this is provided for compatibility.
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://launchpad.net/invada-studio/
+ arch = i686
+ arch = x86_64
+ groups = ladspa-plugins
+ license = GPL2
+ makedepends = ladspa
+ depends = glibc
+ source = https://launchpad.net/invada-studio/ladspa/0.3/+download/invada-studio-plugins_0.3.1-nopkg.tar.gz
+ md5sums = e67fb0db1efd70aa6b340dbff7173420
+
+pkgname = invada-studio-plugins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..942b02d5ef6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: lykwydchykyn <me at alan d moore dot com>
+#
+
+pkgname=invada-studio-plugins
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="LADSPA audio effect plugins from invada, ported from VST. You probably want the LV2 versions, this is provided for compatibility."
+arch=('i686' 'x86_64')
+url="https://launchpad.net/invada-studio/"
+license=('GPL2')
+groups=('ladspa-plugins')
+depends=('glibc')
+makedepends=('ladspa')
+source=("https://launchpad.net/invada-studio/ladspa/0.3/+download/${pkgname}_${pkgver}-nopkg.tar.gz")
+md5sums=('e67fb0db1efd70aa6b340dbff7173420')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i "s|/usr/local|${pkgdir}/usr|g" Makefile
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ echo $pkgdir
+ make INSTALL_SYS_PLUGINS_DIR="${pkgdir}"/usr/lib/ladspa \
+ DESTDIR="$pkgdir" install
+}