summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2022-09-05 23:44:54 +1200
committerVaporeon2022-09-05 23:44:54 +1200
commit9f61cb0644c4eb486ab25f9a3899e17f6cdfb2c9 (patch)
tree29686fad43cec3c80ca711afb814142c89804143
parent5176e43b8c10722ba382b163f0502fd90bf4c167 (diff)
downloadaur-9f61cb0644c4eb486ab25f9a3899e17f6cdfb2c9.tar.gz
Remove usage of mkdir
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 533e2744ae2d..1cfb1f496c94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = invader-git
pkgdesc = An open source toolkit for creating maps and assets for Halo: Combat Evolved (git build)
- pkgver = 0.49.1.r3904.30ce227f
+ pkgver = 0.51.1.r3987.70415776
pkgrel = 1
url = https://invader.opencarnage.net
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d698f3005017..07c77ffafbd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vaporeon <vaporeon@vaporeon.io>
pkgname=invader-git
-pkgver=0.49.1.r3904.30ce227f
+pkgver=0.51.1.r3987.70415776
pkgrel=1
pkgdesc="An open source toolkit for creating maps and assets for Halo: Combat Evolved (git build)"
depends=('libtiff' 'libarchive' 'libsquish' 'flac' 'freetype2' 'libsamplerate'
@@ -23,7 +23,6 @@ pkgver() {
}
prepare() {
- mkdir -p build
cd invader
git submodule init
git config submodule.riat.url "${srcdir}/riat"
@@ -31,14 +30,15 @@ prepare() {
}
build() {
- cd "${srcdir}/build"
- cmake ../${pkgname%-git} -G Ninja \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
- ninja
+ cmake -S "${pkgname%-git}" \
+ -G Ninja \
+ -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ cmake --build build --config Release
}
package() {
- cd "${srcdir}/build"
- ninja install
+ DESTDIR="${pkgdir}" cmake --install build --config Release
}