summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Weber2015-06-14 16:54:49 +0200
committerSteffen Weber2015-06-14 16:54:49 +0200
commitcc542f1ad7f71fb7a7f583db7865963049007c83 (patch)
tree711f2895de5caf1a95269901b4e8c17e23b09ce1
downloadaur-cc542f1ad7f71fb7a7f583db7865963049007c83.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
-rw-r--r--invaders.install27
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72dbcc380e5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = invaders
+ pkgdesc = Multi boot compliant kernel game
+ pkgver = 1.0.0
+ pkgrel = 3
+ url = http://www.erikyyy.de/invaders
+ install = invaders.install
+ arch = i686
+ license = GPL2
+ source = http://www.erikyyy.de/invaders/invaders-1.0.0.tar.gz
+ source = invaders.patch::http://www.coreboot.org/pipermail/coreboot/attachments/20090413/4bd0af62/attachment.ksh
+ md5sums = c5efef690f8c7f3c667cabb696528ab9
+ md5sums = 1ac4007705393aa30a7b81403f81e431
+
+pkgname = invaders
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0950eee5cd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Steffen Weber <-boenki-gmx-de->
+# Contributor: J. Kuske <kuskej@yahoo.com>
+# Contributor: Michal Krenek <mikos@sg1.cz>
+
+pkgname=invaders
+pkgver=1.0.0
+pkgrel=3
+pkgdesc="Multi boot compliant kernel game"
+arch=('i686')
+url="http://www.erikyyy.de/invaders"
+license=('GPL2')
+install=$pkgname.install
+source=($url/$pkgname-$pkgver.tar.gz
+ $pkgname.patch::http://www.coreboot.org/pipermail/coreboot/attachments/20090413/4bd0af62/attachment.ksh)
+md5sums=('c5efef690f8c7f3c667cabb696528ab9'
+ '1ac4007705393aa30a7b81403f81e431')
+
+prepare() {
+ cd $pkgname
+ patch -Np1 -i ../$pkgname.patch
+}
+
+build() {
+ cd $pkgname
+ ./compile.sh
+}
+
+package() {
+ install -Dm644 $pkgname/$pkgname $pkgdir/boot/$pkgname
+} \ No newline at end of file
diff --git a/invaders.install b/invaders.install
new file mode 100644
index 000000000000..125cc595041c
--- /dev/null
+++ b/invaders.install
@@ -0,0 +1,27 @@
+post_install() {
+cat << EOF
+Invaders is a kernel game. For using it please modify your bootloaders.
+
+==> GRUB: add this to /boot/grub/grub.cfg
+menuentry "invaders" {
+ set root=YOURROOTDEVICE
+ multiboot /boot/invaders
+ boot
+}
+
+==> Lilo: add this to lilo.conf
+image = ${_boot}/invaders
+label = "Invaders"
+
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+cat << EOF
+Please remove your additions from your bootloaders.
+EOF
+} \ No newline at end of file