summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2020-03-16 15:49:00 +0900
committerhayao2020-03-16 15:49:00 +0900
commitb81f7845b6dfa76b7324df40e51505f429bf2a25 (patch)
tree2c6b3088dfa7e36db320fe3ec92b3f86c9893819
downloadaur-b81f7845b6dfa76b7324df40e51505f429bf2a25.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..755828953d14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = inverse-icon-theme-blue-git
+ pkgdesc = A colorful Design icon theme for linux desktops
+ pkgver = r13.d6d1cb9
+ pkgrel = 1
+ url = https://github.com/yeyushengfan258/Inverse-icon-theme
+ arch = any
+ license = GPL
+ depends = gtk-update-icon-cache
+ conflicts = inverse-icon-theme-blue
+ source = git+https://github.com/yeyushengfan258/Inverse-icon-theme.git
+ md5sums = SKIP
+
+pkgname = inverse-icon-theme-blue-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3aaa71f6537
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Yamada Hayao <shun819.mail@gmail.com>
+
+pkgname=inverse-icon-theme-blue-git
+_pkgname=inverse-icon-theme
+_gitname=Inverse-icon-theme
+pkgver=r13.d6d1cb9
+pkgrel=1
+pkgdesc="A colorful Design icon theme for linux desktops"
+arch=('any')
+url='https://github.com/yeyushengfan258/Inverse-icon-theme'
+license=('GPL')
+depends=('gtk-update-icon-cache')
+optdepends=()
+source=("git+${url}.git")
+md5sums=('SKIP')
+conflicts=('inverse-icon-theme-blue')
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "${pkgdir}"
+ cp -r * "${pkgdir}"
+ cd "${pkgdir}"
+ mkdir -p "${pkgdir}/usr/share/icons"
+ ${_gitname}/install.sh -blue -d "${pkgdir}/usr/share/icons"
+ rm -rf "${pkgdir}/${_gitname}"
+}