summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2020-03-16 15:34:01 +0900
committerhayao2020-03-16 15:34:01 +0900
commit3422f01f5b531bf45be0e98c8ffc6ce940893ae1 (patch)
tree660c4b9942c65c576e9b471bba56322fc2cd5b77
downloadaur-3422f01f5b531bf45be0e98c8ffc6ce940893ae1.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9893eec20ae7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = inverse-icon-theme-git
+ pkgdesc = A colorful Design icon theme for linux desktops
+ pkgver = r13.d6d1cb9
+ pkgrel = 1
+ url = https://github.com/yeyushengfan258/Inverse-icon-theme
+ arch = any
+ license = GPL
+ depends = gtk-update-icon-cache
+ conflicts = inverse-icon-theme
+ source = git+https://github.com/yeyushengfan258/Inverse-icon-theme.git
+ md5sums = SKIP
+
+pkgname = inverse-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..164b470e7bf7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Yamada Hayao <shun819.mail@gmail.com>
+
+pkgname=inverse-icon-theme-git
+_pkgname=inverse-icon-theme
+_gitname=Inverse-icon-theme
+pkgver=r13.d6d1cb9
+pkgrel=1
+pkgdesc="A colorful Design icon theme for linux desktops"
+arch=('any')
+url='https://github.com/yeyushengfan258/Inverse-icon-theme'
+license=('GPL')
+depends=('gtk-update-icon-cache')
+optdepends=()
+source=("git+${url}.git")
+md5sums=('SKIP')
+conflicts=('inverse-icon-theme')
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "${pkgdir}"
+ cp -r * "${pkgdir}"
+ cd "${pkgdir}"
+ mkdir -p "${pkgdir}/usr/share/icons"
+ ${_gitname}/install.sh -a -d "${pkgdir}/usr/share/icons"
+ rm -rf "${pkgdir}/${_gitname}"
+}