summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkedap2022-04-06 19:00:35 -0500
committerkedap2022-04-06 19:00:35 -0500
commitb8cbf885045b7e6be3bd0af1cd3b2ac31a80a5df (patch)
treefec6d168fb25f89aa2124b6f081aa2ecfdd3d89e
parent4db1a6efb3020d1f89a25b51cf3fd7c53a98603e (diff)
downloadaur-b8cbf885045b7e6be3bd0af1cd3b2ac31a80a5df.tar.gz
update package to 0.1.9
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fc5f599ea39..f88ba59c3e50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,27 @@
pkgbase = invidtui-bin
pkgdesc = A TUI based Invidious client
- pkgver = 0.1.8
- pkgrel = 2
+ pkgver = 0.1.9
+ pkgrel = 1
url = https://github.com/darkhz/invidtui
arch = x86_64
+ arch = arm
+ arch = aarch64
+ arch = armv6h
+ arch = armv7h
license = MIT
depends = mpv
- depends = yt-dlp
- source = https://github.com/darkhz/invidtui/releases/download/v0.1.8/invidtui_0.1.8_Linux_x86_64.tar.gz
- sha256sums = 7eac85b55c7b7dd4353b0e15534b2476bcbed25d4665277acce694d486058ff2
+ depends = youtube-dl
+ depends = ffmpeg
+ provides = invidtui
+ source_x86_64 = https://github.com/darkhz/invidtui/releases/download/v0.1.9/invidtui_0.1.9_Linux_x86_64.tar.gz
+ sha256sums_x86_64 = 790b85baac641dbb4037c4a5dc7d3515c1fa5f350d9bc3f069724b54ad81e91c
+ source_arm = https://github.com/darkhz/invidtui/releases/download/v0.1.9/invidtui_0.1.9_Linux_armv5.tar.gz
+ sha256sums_arm = 291c8b184beaabb7ceed7a2b58fa9f350afec1f6f7feeb4ab2fb51f7fbdd655e
+ source_aarch64 = https://github.com/darkhz/invidtui/releases/download/v0.1.9/invidtui_0.1.9_Linux_arm64.tar.gz
+ sha256sums_aarch64 = 42ea942f608bfc087aab91bb64778e6b2602e3549fe5ec79539bf73cf6388cfe
+ source_armv6h = https://github.com/darkhz/invidtui/releases/download/v0.1.9/invidtui_0.1.9_Linux_armv6.tar.gz
+ sha256sums_armv6h = 1f1fa775f36a9e8c33968c193713bfae97e3521c37942c9da59dd1bb130bcaf0
+ source_armv7h = https://github.com/darkhz/invidtui/releases/download/v0.1.9/invidtui_0.1.9_Linux_armv7.tar.gz
+ sha256sums_armv7h = f83fca8c10173a20d979e18c81467eafc81adcc803c597a06b4270ab5aafa63f
pkgname = invidtui-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6c5b871b227f..2db91b629222 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,27 @@
# Maintainer: kedap <kedap dot dev at protonmail dot com>
pkgname=invidtui-bin
_pkgname=invidtui
-pkgver=0.1.8
-pkgrel=2
+pkgver=0.1.9
+pkgrel=1
pkgdesc="A TUI based Invidious client"
-arch=('x86_64')
+arch=('x86_64' 'arm' 'aarch64' 'armv6h' 'armv7h')
url="https://github.com/darkhz/invidtui"
license=('MIT')
-depends=('mpv' 'yt-dlp')
-source=("https://github.com/darkhz/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_x86_64.tar.gz")
-sha256sums=("7eac85b55c7b7dd4353b0e15534b2476bcbed25d4665277acce694d486058ff2")
+depends=('mpv' 'youtube-dl' 'ffmpeg')
+provides=('invidtui')
+conflics=('invidtui')
+
+source_x86_64=("https://github.com/darkhz/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_x86_64.tar.gz")
+source_arm=("https://github.com/darkhz/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_armv5.tar.gz")
+source_aarch64=("https://github.com/darkhz/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_arm64.tar.gz")
+source_armv6h=("https://github.com/darkhz/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_armv6.tar.gz")
+source_armv7h=("https://github.com/darkhz/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_armv7.tar.gz")
+
+sha256sums_x86_64=("790b85baac641dbb4037c4a5dc7d3515c1fa5f350d9bc3f069724b54ad81e91c")
+sha256sums_arm=("291c8b184beaabb7ceed7a2b58fa9f350afec1f6f7feeb4ab2fb51f7fbdd655e")
+sha256sums_aarch64=("42ea942f608bfc087aab91bb64778e6b2602e3549fe5ec79539bf73cf6388cfe")
+sha256sums_armv6h=("1f1fa775f36a9e8c33968c193713bfae97e3521c37942c9da59dd1bb130bcaf0")
+sha256sums_armv7h=("f83fca8c10173a20d979e18c81467eafc81adcc803c597a06b4270ab5aafa63f")
package() {
install -Dm 755 "${_pkgname}" -t "${pkgdir}/usr/bin"