summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmolith2023-08-31 17:54:13 -0400
committerAmolith2023-08-31 17:54:13 -0400
commit42cf224127c5671b86179305fb57c5332db50e1c (patch)
tree1d1dcc18f3bb81cec7186c7e375058ccf5858d9d
downloadaur-42cf224127c5671b86179305fb57c5332db50e1c.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7481bbfed9ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = invoice-bin
+ pkgdesc = Command line invoice generator
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/maaslalani/invoice
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ license = MIT
+ provides = invoice
+ conflicts = invoice
+ source_x86_64 = https://github.com/maaslalani/invoice/releases/download/v0.1.0/invoice_0.1.0_linux_amd64.tar.gz
+ sha256sums_x86_64 = e78a1e7b71d2562044b6e894ed67eeee2fa9bb299e0ec6bd11cb5e074bbe4728
+ source_i686 = https://github.com/maaslalani/invoice/releases/download/v0.1.0/invoice_0.1.0_linux_386.tar.gz
+ sha256sums_i686 = f97a9048ed07258915aea0a182b33759818c7718d433121ec76091ea77208488
+ source_aarch64 = https://github.com/maaslalani/invoice/releases/download/v0.1.0/invoice_0.1.0_linux_arm64.tar.gz
+ sha256sums_aarch64 = 0e0e2f9afd61c1db6431178dfee3e039c385cf8a9fb4ed47c2df691280395b80
+
+pkgname = invoice-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..45582e44c6e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.zst
+*.tar.gz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9e5dea9bc45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Amolith <amolith@secluded.site
+pkgname=invoice-bin
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Command line invoice generator"
+arch=('x86_64' 'i686' 'aarch64')
+url="https://github.com/maaslalani/${pkgname%-bin}"
+license=('MIT')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+
+source_x86_64=("$url/releases/download/v$pkgver/${pkgname%-bin}_${pkgver}_linux_amd64.tar.gz")
+sha256sums_x86_64=('e78a1e7b71d2562044b6e894ed67eeee2fa9bb299e0ec6bd11cb5e074bbe4728')
+
+source_i686=("$url/releases/download/v$pkgver/${pkgname%-bin}_${pkgver}_linux_386.tar.gz")
+sha256sums_i686=('f97a9048ed07258915aea0a182b33759818c7718d433121ec76091ea77208488')
+
+source_aarch64=("$url/releases/download/v$pkgver/${pkgname%-bin}_${pkgver}_linux_arm64.tar.gz")
+sha256sums_aarch64=('0e0e2f9afd61c1db6431178dfee3e039c385cf8a9fb4ed47c2df691280395b80')
+
+package() {
+ install -Dm755 "${pkgname%-bin}" "$pkgdir/usr/bin/${pkgname%-bin}"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-bin}/LICENSE"
+}