summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwitit2016-03-14 07:26:02 +0700
committerwitit2016-03-14 07:26:02 +0700
commit101d8287ff79facdddae89e53bc5a69d1af704a5 (patch)
tree81726ec681570914e06a83df395006f6c72f918e
parent68a102d5f850c7e0e31ff28146a06e3f0432e7c1 (diff)
downloadaur-101d8287ff79facdddae89e53bc5a69d1af704a5.tar.gz
Update to version 1.4.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94a32d104a68..819a1e6c04f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = invoiceplane
pkgdesc = Self hosted invoicing for freelancers and small businesses
- pkgver = 1.0.2
+ pkgver = 1.4.6
pkgrel = 1
url = https://invoiceplane.com/
arch = any
license = MIT
depends = php
- optdepends = php-mysql: for MySQL database support
- source = https://invoiceplane.com/content/archives/invoiceplane_v1.0.2.zip
- sha512sums = 61742c5fb63aef9148d29f9868239c04ed14375a9ca3c3f33bc3b38dc293880cfe69fcf4a9ffdecf9ebdaee8f48c51094c847307ff516c4e98f91b60f3c5ef30
-
+ source = https://invoiceplane.com/download/v1.4.6
+ md5sums = 6e4fc1bb5446accc6ae2b1907cf1e974
pkgname = invoiceplane
diff --git a/PKGBUILD b/PKGBUILD
index 4050731fe936..0abc4092e408 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=invoiceplane
_pkgname=InvoicePlane
-pkgver=1.4.3
+pkgver=1.4.6
pkgrel=1
pkgdesc="Self hosted invoicing for freelancers and small businesses"
arch=(any)
@@ -11,15 +11,15 @@ url="https://invoiceplane.com/"
license=('MIT')
depends=('php')
optdepends=('php-mysql: for MySQL database support')
-source=("https://github.com/InvoicePlane/InvoicePlane/archive/v1.4.3.tar.gz")
-sha512sums=('5c8a5a646460c3cd7a6ac2ba58a4d44ec771509aa157a32f758d35acb90032f1fbc58caac7fa4823344ec74f682c9edbb9cb4f2481d161cfd40b88be59680b5c')
+source=("https://github.com/InvoicePlane/InvoicePlane/archive/v1.4.6.tar.gz")
+sha512sums=('6bd57bb0ec2c5d04e0ac815bd1da75c175bf50597d5dae7b3b04f8eecd1035f65217e09c56114e930df2219f478df3bea11546ab2003e80d405739bf5f29c9d3')
package() {
cd ${srcdir}
install -vdm0755 $pkgdir/usr/share/webapps
mkdir -p $pkgdir/etc/webapps/invoiceplane
cp -a "${_pkgname}-${pkgver}" ${pkgdir}/usr/share/webapps/invoiceplane
- ln -s /usr/share/webapps/invoiceplane/application/config $pkgdir/etc/webapps/invoiceplane
-
+ chmod +x ${pkgdir}/etc/webapps/invoiceplane
+ ln -s "/etc/webapps/invoiceplane/database.php" "/usr/share/webapps/invoiceplane/application/config/database.php"
install -D "${_pkgname}-${pkgver}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}