summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Wieczorek2016-07-13 02:31:30 +0200
committerMarcin Wieczorek2016-07-13 02:31:30 +0200
commit2efc473525edc15b40b63cf5d665b2b66bdb34e1 (patch)
tree48c3cadc6d7e7268ee9cc755f77184bb8baf182b
parent2c7d3c36f8fd8f3edf8c5f85057cf2dd97500f7f (diff)
downloadaur-2efc473525edc15b40b63cf5d665b2b66bdb34e1.tar.gz
Version 1.4.7
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac5f5433d464..8c172821a11e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = invoiceplane
pkgdesc = Self hosted invoicing for freelancers and small businesses
- pkgver = 1.4.6
+ pkgver = 1.4.7
pkgrel = 1
url = https://invoiceplane.com/
arch = any
license = MIT
depends = php
- source = https://github.com/InvoicePlane/InvoicePlane/archive/v1.4.6.tar.gz
- sha512sums = 6bd57bb0ec2c5d04e0ac815bd1da75c175bf50597d5dae7b3b04f8eecd1035f65217e09c56114e930df2219f478df3bea11546ab2003e80d405739bf5f29c9d3
+ source = https://github.com/InvoicePlane/InvoicePlane/archive/v1.4.7.tar.gz
+ sha512sums = 780d3c3da3d1f7482010bc73948bb0a43d6b11efcb26c135ffdb78bdb9983895ab1eb99749f21d59be64feb08032eb99602c0ff3c47ec61deb56390455efc8f3
pkgname = invoiceplane
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43e40455076c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 58095962540e..df63a515fa91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
-# Submitter: Jonas Heinrich <onny@project-insanity.org>
-# Maintainer: Witit Sujjapong <switit@gmail.com>
+# Maintainer: Marcin Wieczorek <marcin@marcin.co>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Witit Sujjapong <switit@gmail.com>
pkgname=invoiceplane
-_pkgname=InvoicePlane
-pkgver=1.4.6
+pkgver=1.4.7
pkgrel=1
pkgdesc="Self hosted invoicing for freelancers and small businesses"
-arch=(any)
+arch=('any')
url="https://invoiceplane.com/"
license=('MIT')
depends=('php')
#optdepends=('php-mysql: for MySQL database support')
-source=("https://github.com/InvoicePlane/InvoicePlane/archive/v1.4.6.tar.gz")
-sha512sums=('6bd57bb0ec2c5d04e0ac815bd1da75c175bf50597d5dae7b3b04f8eecd1035f65217e09c56114e930df2219f478df3bea11546ab2003e80d405739bf5f29c9d3')
+source=("https://github.com/InvoicePlane/InvoicePlane/archive/v${pkgver}.tar.gz")
+sha512sums=('780d3c3da3d1f7482010bc73948bb0a43d6b11efcb26c135ffdb78bdb9983895ab1eb99749f21d59be64feb08032eb99602c0ff3c47ec61deb56390455efc8f3')
package() {
- install -d "$pkgdir"/usr/share/webapps
- cp -a "$_pkgname-$pkgver" "$pkgdir"/usr/share/webapps/invoiceplane
-
- install -Dm644 "$_pkgname-$pkgver"/license.txt "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
-} \ No newline at end of file
+ install -d "${pkgdir}/usr/share/webapps"
+ cp -a "InvoicePlane-${pkgver}" "$pkgdir/usr/share/webapps/invoiceplane"
+ install -Dm644 "InvoicePlane-${pkgver}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}