summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwitit2016-03-15 11:31:00 +0700
committerwitit2016-03-15 11:31:00 +0700
commit5daa16a6f4a82fda3c28495bf4e0083a855438c0 (patch)
treea576cf7ee9d84e7925de2abedf5cd796149880b3
parent5d65d23a81dc62a9c38c2c012d0cc9939c5e2271 (diff)
downloadaur-5daa16a6f4a82fda3c28495bf4e0083a855438c0.tar.gz
tidy up pkgbuild
-rw-r--r--PKGBUILD20
1 files changed, 2 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44a9304b1313..32b4c47694ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,26 +15,10 @@ source=("https://github.com/InvoicePlane/InvoicePlane/archive/v1.4.6.tar.gz")
sha512sums=('6bd57bb0ec2c5d04e0ac815bd1da75c175bf50597d5dae7b3b04f8eecd1035f65217e09c56114e930df2219f478df3bea11546ab2003e80d405739bf5f29c9d3')
package() {
- # Each of these functions start in the $srcdir already.
-
- # Quote variables to prevent word splitting.
- # See <http://mywiki.wooledge.org/Quotes#When_Should_You_Quote.3F>
-
install -d "$pkgdir"/usr/share/webapps
-
- # Consistency.
install -d "$pkgdir"/etc/webapps/invoiceplane
-
- # Note that -a with --preserve=all only works here as package() is run
- # under fakeroot, otherwise you'd use -dr --no-preserve=ownership
cp -a "$_pkgname-$pkgver" "$pkgdir"/usr/share/webapps/invoiceplane
-
- # This is temporarily a broken symlink but will be correct once installed.
- file=""$pkgdir"/usr/share/webapps/invoiceplane/application/config/database.php"
- if [ -f $file ] ; then
- rm $file
- fi
- ln -s /etc/webapps/invoiceplane/database.php "$pkgdir"/usr/share/webapps/invoiceplane/application/config/database.php
+ ln -fs /etc/webapps/invoiceplane/database.php "$pkgdir"/usr/share/webapps/invoiceplane/application/config/database.php
install -Dm644 "$_pkgname-$pkgver"/license.txt "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
-}
+} \ No newline at end of file