summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2015-08-03 14:35:14 +0000
committerJonas Heinrich2015-08-03 14:35:14 +0000
commit68a102d5f850c7e0e31ff28146a06e3f0432e7c1 (patch)
treeb8006b116f017e64b33adf9e19f99c57d566254c
downloadaur-68a102d5f850c7e0e31ff28146a06e3f0432e7c1.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94a32d104a68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = invoiceplane
+ pkgdesc = Self hosted invoicing for freelancers and small businesses
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://invoiceplane.com/
+ arch = any
+ license = MIT
+ depends = php
+ optdepends = php-mysql: for MySQL database support
+ source = https://invoiceplane.com/content/archives/invoiceplane_v1.0.2.zip
+ sha512sums = 61742c5fb63aef9148d29f9868239c04ed14375a9ca3c3f33bc3b38dc293880cfe69fcf4a9ffdecf9ebdaee8f48c51094c847307ff516c4e98f91b60f3c5ef30
+
+pkgname = invoiceplane
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4050731fe936
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Submitter: Jonas Heinrich <onny@project-insanity.org>
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=invoiceplane
+_pkgname=InvoicePlane
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="Self hosted invoicing for freelancers and small businesses"
+arch=(any)
+url="https://invoiceplane.com/"
+license=('MIT')
+depends=('php')
+optdepends=('php-mysql: for MySQL database support')
+source=("https://github.com/InvoicePlane/InvoicePlane/archive/v1.4.3.tar.gz")
+sha512sums=('5c8a5a646460c3cd7a6ac2ba58a4d44ec771509aa157a32f758d35acb90032f1fbc58caac7fa4823344ec74f682c9edbb9cb4f2481d161cfd40b88be59680b5c')
+
+package() {
+ cd ${srcdir}
+ install -vdm0755 $pkgdir/usr/share/webapps
+ mkdir -p $pkgdir/etc/webapps/invoiceplane
+ cp -a "${_pkgname}-${pkgver}" ${pkgdir}/usr/share/webapps/invoiceplane
+ ln -s /usr/share/webapps/invoiceplane/application/config $pkgdir/etc/webapps/invoiceplane
+
+ install -D "${_pkgname}-${pkgver}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}