summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Weber2016-03-04 20:23:18 +0100
committerJonas Weber2016-03-04 20:31:13 +0100
commit23fb903072e6026b827639e8f0630117ac409bc9 (patch)
treedd764472ab6f9e066cffa7f9d995752d2eaafa4c
downloadaur-23fb903072e6026b827639e8f0630117ac409bc9.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b67d0340c127
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = involucro
+ pkgdesc = build and deliver software with containers
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/thriqon/involucro
+ arch = x86_64
+ arch = i686
+ license = Apache
+ makedepends = go
+ makedepends = gzip
+ depends = glibc
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/thriqon/involucro/archive/v1.0.1.tar.gz
+ sha1sums = 7bcdbb8f6b246e60adaaffbfd2340e227bebd013
+
+pkgname = involucro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4ab90749721
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: thriqon <mail@jonasw.de>
+
+pkgname=involucro
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="build and deliver software with containers"
+arch=('x86_64' 'i686')
+url="https://github.com/thriqon/involucro"
+license=('Apache')
+depends=('glibc')
+makedepends=('go' 'gzip')
+options=('!strip' '!emptydirs')
+source=("https://github.com/thriqon/involucro/archive/v1.0.1.tar.gz")
+sha1sums=("7bcdbb8f6b246e60adaaffbfd2340e227bebd013")
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ go build -ldflags "-s -w -X github.com/thriqon/involucro/app.version=$pkgver" ./cmd/involucro
+ gzip -f docs/involucro.1
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 docs/involucro.1.gz "$pkgdir/usr/share/man/man1/involucro.1.gz"
+}
+
+# vim:set ts=2 sw=2 et: