summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-03-26 23:17:47 +0200
committerFabioLolix2018-03-26 23:17:47 +0200
commit29fdf3d1b7c6a1da73ca09eb755e0dee392fdcca (patch)
tree6e7d294188ec314073b3622cd7fc05b6c70eac1b
parent92f11f32f3112c3cf8f725ef1477f581763e4b9d (diff)
downloadaur-29fdf3d1b7c6a1da73ca09eb755e0dee392fdcca.tar.gz
v2.9.07
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD41
2 files changed, 38 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76f2c03a86da..171edfbc86aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
-# Generated by mksrcinfo v8
-# Tue Mar 20 15:43:55 UTC 2018
pkgbase = inxi
pkgdesc = script to get system information
- pkgver = 2.3.56
+ pkgver = 2.9.07
pkgrel = 1
- url = http://inxi.org
+ url = https://github.com/smxi/inxi
arch = any
license = GPL
depends = coreutils
depends = gawk
depends = grep
depends = pciutils
+ depends = perl
depends = procps-ng
depends = sed
optdepends = dmidecode: inxi -M if no sys machine data
@@ -27,8 +26,9 @@ pkgbase = inxi
optdepends = xorg-xdpyinfo: inxi -G multi screen resolution
optdepends = xorg-xprop: inxi -S desktop data
optdepends = xorg-xrandr: inxi -G single screen resolution
- source = https://sources.archlinux.org/other/community/inxi/inxi-2.3.56.tar.gz
- md5sums = 8cde8559d31b82d478bc1a5788cc7bcd
+ options = zipman
+ source = inxi-2.9.07-1.tar.gz::https://github.com/smxi/inxi/archive/0f0433dc9ae2bf5250d6939e207bb3e94d9b7ae9.tar.gz
+ sha256sums = 04b2011a0ea9b0e0ac1a4d099ca115c65c1bbc3bbe3dcedc30a99e00df0d9ee2
pkgname = inxi
diff --git a/PKGBUILD b/PKGBUILD
index 4a33dca93f74..af2f4db4a82a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,16 @@
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Stefano Capitani <stefanoatmanjarodotorg>
# Contributor: Florian Pritz <f-p@gmx.at>
+
pkgname=inxi
-pkgver=2.3.56
+pkgver=2.9.07
pkgrel=1
pkgdesc="script to get system information"
arch=('any')
-url="http://inxi.org"
+url="https://github.com/smxi/inxi"
license=('GPL')
-depends=(coreutils gawk grep pciutils procps-ng sed)
+depends=('coreutils' 'gawk' 'grep' 'pciutils' 'perl' 'procps-ng' 'sed')
+_commit=0f0433dc9ae2bf5250d6939e207bb3e94d9b7ae9
optdepends=(
"dmidecode: inxi -M if no sys machine data"
"file: inxi -o unmounted file system"
@@ -23,13 +27,32 @@ optdepends=(
"xorg-xprop: inxi -S desktop data"
"xorg-xrandr: inxi -G single screen resolution"
)
-source=(https://sources.archlinux.org/other/community/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('8cde8559d31b82d478bc1a5788cc7bcd')
+options=('zipman')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$_commit.tar.gz")
+sha256sums=('04b2011a0ea9b0e0ac1a4d099ca115c65c1bbc3bbe3dcedc30a99e00df0d9ee2')
+
+pkgver() {
+ cd $pkgname-$_commit
+
+ # change version
+ awk '/self_version=/ {print $2}' inxi | cut -c 16-21
+}
+
+prepare() {
+ cd $pkgname-$_commit
+
+ # temp move inxi to pinxi
+ mv inxi pinxi
+
+ # patches here
+
+ # temp move pinxi back to inxi
+ mv pinxi inxi
+}
package() {
- cd "$srcdir"
- install -D -m755 inxi "$pkgdir/usr/bin/inxi"
- install -D -m755 inxi.1.gz "$pkgdir/usr/share/man/man1/inxi.1.gz"
+ cd "$srcdir/$pkgname-$_commit"
+ install -D -m755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -D -m755 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
}
-# vim:set ts=2 sw=2 et: