summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-03-21 12:57:21 +0100
committerFabioLolix2021-03-21 12:57:21 +0100
commit412c78b81ceb1673e93cfd7356dfd62d341ca884 (patch)
tree076202c5887c894a726c67ee0c072a0c9f72ed18
parentf3eda94cec49b6612a1a71ac1b2fdcf0100bcd8e (diff)
downloadaur-412c78b81ceb1673e93cfd7356dfd62d341ca884.tar.gz
v3.03.1, update url
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD52
2 files changed, 36 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f54310eadab..ac77788b1b33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = inxi
pkgdesc = Full featured CLI system information tool
- pkgver = 3.3.01.1
+ pkgver = 3.3.03.1
pkgrel = 1
- url = https://github.com/smxi/inxi
+ url = https://smxi.org/docs/inxi.htm
arch = any
license = GPL3
depends = coreutils
depends = pciutils
depends = perl
depends = procps-ng
+ optdepends = bluez-tools: bt-adapter: -E bluetooth data (if no hciconfig)
optdepends = bluez-utils-compat: hciconfig: -E bluetooth HCI data
- optdepends = bind-tools: -i wlan IP
+ optdepends = bind: -i wlan IP
optdepends = dmidecode: inxi -M if no sys machine data
optdepends = file: inxi -o unmounted file system
+ optdepends = freeipmi: ipmi-sensors: -s IPMI sensors
optdepends = hddtemp: inxi -Dx show hdd temp
optdepends = iproute2: inxi -i ip lan
+ optdepends = ipmitool: -s IPMI sensors
optdepends = kmod: inxi -Ax,-Nx module version
optdepends = lm_sensors: inxi -s sensors output
optdepends = mesa-demos: inxi -G glx info
@@ -26,12 +29,13 @@ pkgbase = inxi
optdepends = systemd-sysvcompat: inxi -I runlevel
optdepends = sudo: inxi -Dx hddtemp-user;-o file-user
optdepends = tree: --debugger 20,21 /sys tree
+ optdepends = upower: -sx attached device battery info
optdepends = usbutils: inxi -A usb audio;-N usb networking
optdepends = wmctrl: -S active window manager (not all wm)
optdepends = xorg-xdpyinfo: inxi -G multi screen resolution
optdepends = xorg-xprop: inxi -S desktop data
optdepends = xorg-xrandr: inxi -G single screen resolution
- source = inxi-3.3.01.1.tar.gz::https://github.com/smxi/inxi/archive/3.3.01-1.tar.gz
+ source = inxi-3.3.03.1.tar.gz::https://github.com/smxi/inxi/archive/3.3.03-1.tar.gz
sha256sums = 1439a6bb220dbe0aea03d4a9e375e48a28f340a48532da2c15782b661feabcc3
pkgname = inxi
diff --git a/PKGBUILD b/PKGBUILD
index 77e444ee8d1f..798b0d847425 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,41 @@
# Contributor: Florian Pritz <f-p@gmx.at>
pkgname=inxi
-_pkgver=3.3.01-1
+_pkgver=3.3.03-1
pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Full featured CLI system information tool"
arch=(any)
-url="https://github.com/smxi/inxi"
+url="https://smxi.org/docs/inxi.htm"
license=(GPL3)
depends=(coreutils pciutils perl procps-ng)
optdepends=(
- "bluez-utils-compat: hciconfig: -E bluetooth HCI data"
- "bind-tools: -i wlan IP"
- "dmidecode: inxi -M if no sys machine data"
- "file: inxi -o unmounted file system"
- "hddtemp: inxi -Dx show hdd temp"
- "iproute2: inxi -i ip lan"
- "kmod: inxi -Ax,-Nx module version"
- "lm_sensors: inxi -s sensors output"
- "mesa-demos: inxi -G glx info"
- "net-tools: inxi -i ip lan-deprecated"
- "perl-io-socket-ssl: -U; -w,-W; -i (if dig not installed)"
- "perl-cpanel-json-xs: --output json - required for export"
- "perl-json-xs: --output json - required for export (legacy)"
- "perl-xml-dumper: --output xml - Crude and raw"
- "systemd-sysvcompat: inxi -I runlevel"
- "sudo: inxi -Dx hddtemp-user;-o file-user"
- "tree: --debugger 20,21 /sys tree"
- "usbutils: inxi -A usb audio;-N usb networking"
- "wmctrl: -S active window manager (not all wm)"
- "xorg-xdpyinfo: inxi -G multi screen resolution"
- "xorg-xprop: inxi -S desktop data"
- "xorg-xrandr: inxi -G single screen resolution"
+ "bluez-tools: bt-adapter: -E bluetooth data (if no hciconfig)"
+ "bluez-utils-compat: hciconfig: -E bluetooth HCI data"
+ "bind: -i wlan IP"
+ "dmidecode: inxi -M if no sys machine data"
+ "file: inxi -o unmounted file system"
+ "freeipmi: ipmi-sensors: -s IPMI sensors"
+ "hddtemp: inxi -Dx show hdd temp"
+ "iproute2: inxi -i ip lan"
+ "ipmitool: -s IPMI sensors"
+ "kmod: inxi -Ax,-Nx module version"
+ "lm_sensors: inxi -s sensors output"
+ "mesa-demos: inxi -G glx info"
+ "net-tools: inxi -i ip lan-deprecated"
+ "perl-io-socket-ssl: -U; -w,-W; -i (if dig not installed)"
+ "perl-cpanel-json-xs: --output json - required for export"
+ "perl-json-xs: --output json - required for export (legacy)"
+ "perl-xml-dumper: --output xml - Crude and raw"
+ "systemd-sysvcompat: inxi -I runlevel"
+ "sudo: inxi -Dx hddtemp-user;-o file-user"
+ "tree: --debugger 20,21 /sys tree"
+ "upower: -sx attached device battery info"
+ "usbutils: inxi -A usb audio;-N usb networking"
+ "wmctrl: -S active window manager (not all wm)"
+ "xorg-xdpyinfo: inxi -G multi screen resolution"
+ "xorg-xprop: inxi -S desktop data"
+ "xorg-xrandr: inxi -G single screen resolution"
)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/smxi/inxi/archive/${_pkgver}.tar.gz")
sha256sums=('1439a6bb220dbe0aea03d4a9e375e48a28f340a48532da2c15782b661feabcc3')