summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-06-01 07:05:08 +0200
committerFabioLolix2018-06-01 07:05:08 +0200
commitee3a9587fe76d9ad8b1a023822c90e8863d980a6 (patch)
tree31381d70ff9fc87170a1b447d4e29ee840ab1bf6
parent09af9841dca870d70d08bce5b4f03cbd35471e72 (diff)
downloadaur-ee3a9587fe76d9ad8b1a023822c90e8863d980a6.tar.gz
v3.0.10, update deps & optdeps
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD25
2 files changed, 32 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea0c0623c993..39265f84fd42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,38 @@
pkgbase = inxi
- pkgdesc = script to get system information
- pkgver = 3.0.09
- pkgrel = 1
+ pkgdesc = Full featured CLI system information tool
+ pkgver = 3.0.10
+ pkgrel = 2
url = https://github.com/smxi/inxi
arch = any
license = GPL
depends = coreutils
- depends = gawk
- depends = grep
depends = pciutils
depends = perl
depends = procps-ng
- depends = sed
+ optdepends = bind-tools: -i wlan IP
optdepends = dmidecode: inxi -M if no sys machine data
optdepends = file: inxi -o unmounted file system
optdepends = hddtemp: inxi -Dx show hdd temp
- optdepends = net-tools: inxi -i ip lan-deprecated
optdepends = iproute2: inxi -i ip lan
- optdepends = lm_sensors: inxi -s sensors output
- optdepends = usbutils: inxi -A usb audio;-N usb networking
optdepends = kmod: inxi -Ax,-Nx module version
+ optdepends = lm_sensors: inxi -s sensors output
+ optdepends = mesa-demos: inxi -G glx info
+ optdepends = net-tools: inxi -i ip lan-deprecated
+ optdepends = perl-io-socket-ssl: -U; -w,-W; -i (if dig not installed)
+ optdepends = perl-cpanel-json-xs: --output json - required for export
+ optdepends = perl-json-xs: --output json - required for export (legacy)
+ optdepends = perl-xml-dumper: --output xml - Crude and raw
optdepends = systemd-sysvcompat: inxi -I runlevel
optdepends = sudo: inxi -Dx hddtemp-user;-o file-user
- optdepends = mesa-demos: inxi -G glx info
+ optdepends = tree: --debugger 20,21 /sys tree
+ optdepends = usbutils: inxi -A usb audio;-N usb networking
+ optdepends = wmctrl: -S active window manager (not all wm)
optdepends = xorg-xdpyinfo: inxi -G multi screen resolution
optdepends = xorg-xprop: inxi -S desktop data
optdepends = xorg-xrandr: inxi -G single screen resolution
options = zipman
- source = inxi-3.0.09.tar.gz::https://github.com/smxi/inxi/archive/3.0.09-1.tar.gz
- sha256sums = 982200d41c4c5c85ea1917d226c4da0076d88afc0ab5a6b79f790a0e9b9790c7
+ source = inxi-3.0.10.tar.gz::https://github.com/smxi/inxi/archive/3.0.10-1.tar.gz
+ sha256sums = f09f6d69d961b7bc53e7457fc3f8e7e86e1bd34b2a4dd1e6aa38f436d9e5c855
pkgname = inxi
diff --git a/PKGBUILD b/PKGBUILD
index 3e6fd07042cc..669876928ee9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,39 @@
# Contributor: Florian Pritz <f-p@gmx.at>
pkgname=inxi
-pkgver=3.0.09
-pkgrel=1
-pkgdesc="script to get system information"
+pkgver=3.0.10
+pkgrel=2
+pkgdesc="Full featured CLI system information tool"
arch=('any')
url="https://github.com/smxi/inxi"
license=('GPL')
-depends=('coreutils' 'gawk' 'grep' 'pciutils' 'perl' 'procps-ng' 'sed')
+depends=('coreutils' 'pciutils' 'perl' 'procps-ng')
optdepends=(
+ "bind-tools: -i wlan IP"
"dmidecode: inxi -M if no sys machine data"
"file: inxi -o unmounted file system"
"hddtemp: inxi -Dx show hdd temp"
- "net-tools: inxi -i ip lan-deprecated"
"iproute2: inxi -i ip lan"
- "lm_sensors: inxi -s sensors output"
- "usbutils: inxi -A usb audio;-N usb networking"
"kmod: inxi -Ax,-Nx module version"
+ "lm_sensors: inxi -s sensors output"
+ "mesa-demos: inxi -G glx info"
+ "net-tools: inxi -i ip lan-deprecated"
+ "perl-io-socket-ssl: -U; -w,-W; -i (if dig not installed)"
+ "perl-cpanel-json-xs: --output json - required for export"
+ "perl-json-xs: --output json - required for export (legacy)"
+ "perl-xml-dumper: --output xml - Crude and raw"
"systemd-sysvcompat: inxi -I runlevel"
"sudo: inxi -Dx hddtemp-user;-o file-user"
- "mesa-demos: inxi -G glx info"
+ "tree: --debugger 20,21 /sys tree"
+ "usbutils: inxi -A usb audio;-N usb networking"
+ "wmctrl: -S active window manager (not all wm)"
"xorg-xdpyinfo: inxi -G multi screen resolution"
"xorg-xprop: inxi -S desktop data"
"xorg-xrandr: inxi -G single screen resolution"
)
options=('zipman')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/smxi/inxi/archive/${pkgver}-1.tar.gz")
-sha256sums=('982200d41c4c5c85ea1917d226c4da0076d88afc0ab5a6b79f790a0e9b9790c7')
+sha256sums=('f09f6d69d961b7bc53e7457fc3f8e7e86e1bd34b2a4dd1e6aa38f436d9e5c855')
package() {
cd "${pkgname}-${pkgver}-1"