summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-04-14 16:08:05 +0200
committerFabioLolix2018-04-14 16:08:05 +0200
commitf02c6358ea71c5b938a8b14cd3b47a6700b80021 (patch)
tree7d7d7523cd9921ace2874ae2fe67ff27207fed55
parent10d1289de05e2772be11a8f7a489f9ac381f021c (diff)
downloadaur-f02c6358ea71c5b938a8b14cd3b47a6700b80021.tar.gz
v3.0.03
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
2 files changed, 7 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db727aa953e7..1363afbcf9cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = inxi
pkgdesc = script to get system information
- pkgver = 2.9.12
+ pkgver = 3.0.03
pkgrel = 1
url = https://github.com/smxi/inxi
arch = any
@@ -27,8 +27,8 @@ pkgbase = inxi
optdepends = xorg-xprop: inxi -S desktop data
optdepends = xorg-xrandr: inxi -G single screen resolution
options = zipman
- source = inxi-2.9.12.tar.gz::https://github.com/smxi/inxi/archive/e43933452fb8f99fee31a26d7adf03b670c5ffab.tar.gz
- sha256sums = b6c041bff3189bfc662eb72eb7ba3ca9bb19c408e4ababaeea723a91e5198224
+ source = inxi-3.0.03::https://github.com/smxi/inxi/archive/3.0.03-1.tar.gz
+ sha256sums = 80f2fef56567311dcae9a70c7d592cbc516c4000a643a5a9b938a28c12c5a90d
pkgname = inxi
diff --git a/PKGBUILD b/PKGBUILD
index 816ca090e66b..5a25acae522f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Florian Pritz <f-p@gmx.at>
pkgname=inxi
-pkgver=2.9.12
+pkgver=3.0.03
pkgrel=1
pkgdesc="script to get system information"
arch=('any')
@@ -27,31 +27,11 @@ optdepends=(
"xorg-xrandr: inxi -G single screen resolution"
)
options=('zipman')
-_commit=e43933452fb8f99fee31a26d7adf03b670c5ffab
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$_commit.tar.gz")
-sha256sums=('b6c041bff3189bfc662eb72eb7ba3ca9bb19c408e4ababaeea723a91e5198224')
-
-pkgver() {
- cd "${pkgname}-${_commit}"
-
- # change version
- awk '/self_version=/ {print $2}' inxi | cut -c 16-21
-}
-
-prepare() {
- cd "${pkgname}-${_commit}"
-
- # temp move inxi to pinxi
- mv inxi pinxi
-
- # patches here
-
- # temp move pinxi back to inxi
- mv pinxi inxi
-}
+source=("${pkgname}-${pkgver}::https://github.com/smxi/inxi/archive/${pkgver}-1.tar.gz")
+sha256sums=('80f2fef56567311dcae9a70c7d592cbc516c4000a643a5a9b938a28c12c5a90d')
package() {
- cd "${pkgname}-${_commit}"
+ cd "${pkgname}-${pkgver}-1"
install -D -m755 $pkgname "${pkgdir}/usr/bin/$pkgname"
install -D -m755 $pkgname.1 "${pkgdir}/usr/share/man/man1/$pkgname.1"
}