summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElTh0r02020-03-22 17:36:23 +0100
committerElTh0r02020-03-22 17:36:23 +0100
commit01bd581cdea1abe21c3ba7611a4c2681860ad49d (patch)
treec4012968c22417b5fd8cc5878f4b551467a1ce5f
downloadaur-01bd581cdea1abe21c3ba7611a4c2681860ad49d.tar.gz
Initial AUR release
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d415583201d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = inyokaedit-data-ubuntuusersde
+ pkgdesc = ubuntuusers.de community files for InyokaEdit
+ pkgver = 0.24.0
+ pkgrel = 1
+ url = https://github.com/inyokaproject/inyokaedit/
+ arch = any
+ license = GPL3
+ depends = bash
+ optdepends = inyokaedit: Editor for Inyoka based portals
+ optdepends = inyokaedit-plugins: Plugins for InyokaEdit
+ source = https://github.com/inyokaproject/inyokaedit/releases/download/v0.24.0/inyokaedit-community-0.24.0.zip
+ sha256sums = 438e4699b0267d54a514efeba9ebe9131ec0bbc1bc379bc34e0d19fe14217539
+
+pkgname = inyokaedit-data-ubuntuusersde
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..64188e4be493
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Thorsten Roth <elthoro@gmx.de>
+pkgname=inyokaedit-data-ubuntuusersde
+pkgver=0.24.0
+pkgrel=1
+_lang=de_DE # Need to set LC_CTYPE/LANG because of filenames with special characters
+pkgdesc='ubuntuusers.de community files for InyokaEdit'
+arch=('any')
+url='https://github.com/inyokaproject/inyokaedit/'
+license=('GPL3')
+depends=('bash')
+optdepends=('inyokaedit: Editor for Inyoka based portals'
+ 'inyokaedit-plugins: Plugins for InyokaEdit')
+source=("https://github.com/inyokaproject/inyokaedit/releases/download/v$pkgver/inyokaedit-community-$pkgver.zip")
+sha256sums=('438e4699b0267d54a514efeba9ebe9131ec0bbc1bc379bc34e0d19fe14217539')
+
+build() {
+ mv inyokaedit-community/ community/
+ wget -nv "$url/raw/v$pkgver/configure" -O configure
+ chmod +x configure
+ wget -nv "$url/raw/v$pkgver/Makefile" -O Makefile
+ chmod +x Makefile
+ ./configure --prefix=/usr --community=ubuntuusers_de
+}
+
+package() {
+ export LC_CTYPE=$_lang.UTF-8
+ export LANG=$_lang.UTF-8
+ make DESTDIR="$pkgdir/" install-data-ubuntuusersde
+}