summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElTh0r02024-03-31 16:06:35 +0200
committerElTh0r02024-03-31 16:06:35 +0200
commitb43dba144e3eb8fbf69aca310518dbbf624f16e1 (patch)
treec8fa5236382b696922243c22058ee9c8de34df72
parentf6d177d76550975403999dbbbad8d324ae81beef (diff)
downloadaur-b43dba144e3eb8fbf69aca310518dbbf624f16e1.tar.gz
v0.28.0
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD16
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7df3994b161..931cd2419c2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = inyokaedit-data-ubuntuusersde
pkgdesc = ubuntuusers.de community files for InyokaEdit
- pkgver = 0.27.4
+ pkgver = 0.28.0
pkgrel = 1
url = https://github.com/inyokaproject/inyokaedit/
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
depends = bash
optdepends = inyokaedit: Editor for Inyoka based portals
optdepends = inyokaedit-plugins: Plugins for InyokaEdit
- source = https://github.com/inyokaproject/inyokaedit/releases/download/v0.27.4/inyokaedit-community-0.27.4.zip
+ source = https://github.com/inyokaproject/inyokaedit/releases/download/v0.28.0/inyokaedit-community-0.28.0.zip
sha256sums = 10b1761e0bdd11cb8dc6a5b5b69c639f37a2a2e812a259b82ce4c3c631388d67
pkgname = inyokaedit-data-ubuntuusersde
diff --git a/PKGBUILD b/PKGBUILD
index da2dc7e5c70f..610008d4715e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Thorsten Roth <elthoro@gmx.de>
pkgname=inyokaedit-data-ubuntuusersde
-pkgver=0.27.4
+pkgver=0.28.0
pkgrel=1
_lang=de_DE # Need to set LC_CTYPE/LANG because of filenames with special characters
pkgdesc='ubuntuusers.de community files for InyokaEdit'
arch=('any')
url='https://github.com/inyokaproject/inyokaedit/'
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('bash')
optdepends=('inyokaedit: Editor for Inyoka based portals'
'inyokaedit-plugins: Plugins for InyokaEdit')
@@ -15,15 +15,15 @@ sha256sums=('10b1761e0bdd11cb8dc6a5b5b69c639f37a2a2e812a259b82ce4c3c631388d67')
build() {
mv inyokaedit-community/ community/
- wget -nv "$url/raw/v$pkgver/configure" -O configure
- chmod +x configure
- wget -nv "$url/raw/v$pkgver/Makefile" -O Makefile
- chmod +x Makefile
- ./configure --prefix=/usr --community=ubuntuusers_de
+ wget -nv "$url/raw/v$pkgver/CMakeLists.txt" -O CMakeLists.txt
+ cmake -B build-cmake -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DBUILD_COMMUNITY_ONLY=ON \
+ -DBUILD_APPLICATION=OFF \
+ -DCOMMUNITY=community/ubuntuusers_de
}
package() {
export LC_CTYPE=$_lang.UTF-8
export LANG=$_lang.UTF-8
- make DESTDIR="$pkgdir/" install-data-ubuntuusersde
+ DESTDIR="$pkgdir/" cmake --install build-cmake
}