summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Rødseth2017-06-09 13:47:04 +0000
committerAlexander Rødseth2017-06-09 13:47:04 +0000
commite38d2af8ad67daeeccc3defaee013dcc3d82dc1c (patch)
tree2eb5af32a1c8a746077f0f1396c0ac9d5e8a695f
parentf3dc9f603ef15c14037ed502b805b720fa288528 (diff)
downloadaur-e38d2af8ad67daeeccc3defaee013dcc3d82dc1c.tar.gz
upgpkg: 2017.06.09-1
-rw-r--r--PATCH-Fix-for-inlining-in-C11-mode.patch57
-rw-r--r--PATCH-added--msse2-to-compile-flags-for.patch23
-rw-r--r--PKGBUILD30
3 files changed, 10 insertions, 100 deletions
diff --git a/PATCH-Fix-for-inlining-in-C11-mode.patch b/PATCH-Fix-for-inlining-in-C11-mode.patch
deleted file mode 100644
index 0efd48ab7915..000000000000
--- a/PATCH-Fix-for-inlining-in-C11-mode.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 2ab9505240c7d32ea5cb4d367c86af0146ac0b7c Mon Sep 17 00:00:00 2001
-From: Peter Hull <peterhull90@gmail.com>
-Date: Sun, 24 Jan 2016 13:19:27 +0000
-Subject: [PATCH] Fix for inlining in C11 mode
-
----
- libs/basekit/source/Common_inline.h | 36 ++++++++++++++++++++++++------------
- 1 file changed, 24 insertions(+), 12 deletions(-)
-
-diff --git a/libs/basekit/source/Common_inline.h b/libs/basekit/source/Common_inline.h
-index a4086d7..19f8d47 100755
---- a/libs/basekit/source/Common_inline.h
-+++ b/libs/basekit/source/Common_inline.h
-@@ -117,19 +117,31 @@ Kudos to Daniel A. Koepke
- #endif
-
- #elif defined(__linux__) || defined(__OpenBSD__) || defined(__NetBSD__) || defined(__FreeBSD__)
--
-- #ifdef IO_IN_C_FILE
-- // in .c
-- #define IO_DECLARE_INLINES
-- #define IOINLINE inline
-- #define IOINLINE_RECURSIVE inline
-+ #ifdef __GNUC_STDC_INLINE__
-+ #ifdef IO_IN_C_FILE
-+ // in .c
-+ #define IO_DECLARE_INLINES
-+ #define IOINLINE
-+ #define IOINLINE_RECURSIVE
-+ #else
-+ // in .h
-+ #define IO_DECLARE_INLINES
-+ #define IOINLINE inline
-+ #define IOINLINE_RECURSIVE inline
-+ #endif
- #else
-- // in .h
-- #define IO_DECLARE_INLINES
-- #define IOINLINE extern inline
-- #define IOINLINE_RECURSIVE extern inline
-- #endif
--
-+ #ifdef IO_IN_C_FILE
-+ // in .c
-+ #define IO_DECLARE_INLINES
-+ #define IOINLINE inline
-+ #define IOINLINE_RECURSIVE inline
-+ #else
-+ // in .h
-+ #define IO_DECLARE_INLINES
-+ #define IOINLINE extern inline
-+ #define IOINLINE_RECURSIVE extern inline
-+ #endif
-+ #endif
- #else
-
- #ifdef IO_IN_C_FILE
diff --git a/PATCH-added--msse2-to-compile-flags-for.patch b/PATCH-added--msse2-to-compile-flags-for.patch
deleted file mode 100644
index e9f8b99fc608..000000000000
--- a/PATCH-added--msse2-to-compile-flags-for.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 2ca83eac52092eb297b7f3cee3d6057377e57c67 Mon Sep 17 00:00:00 2001
-From: Peter Hull <peterhull90@gmail.com>
-Date: Mon, 25 Jan 2016 09:21:13 +0000
-Subject: [PATCH] Added -msse2 to compile flags for all sources. Under GCC 5
- it's needed, otherwise compiling UArray_math.c fails.
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7e3a3bc..e6d19e5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -39,7 +39,7 @@ IF(CMAKE_COMPILER_IS_GNUCC)
- SET(CMAKE_BUILD_TYPE_DebugFast)
- SET(CMAKE_CXX_FLAGS_DEBUGFAST "-g -O0")
- SET(CMAKE_C_FLAGS_DEBUGFAST "-g -O0")
--
-+ SET(CMAKE_C_FLAGS "-msse2")
- if(NOT CMAKE_BUILD_TYPE)
- SET(CMAKE_BUILD_TYPE "DebugFast")
- endif(NOT CMAKE_BUILD_TYPE)
diff --git a/PKGBUILD b/PKGBUILD
index 105ce7a0405e..5f33d4d3a744 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,32 @@
# Contributor: Gergely Imreh <imrehg@gmail.com>
pkgname=io
-pkgver=2015.11.11
-pkgrel=7
+pkgver=2017.06.09
+pkgrel=1
pkgdesc='IO programming language'
arch=('x86_64' 'i686')
url='http://iolanguage.com/'
license=('BSD')
-depends=('pcre' 'libsndfile' 'libxmu' 'freetype2' 'libedit' 'libxml2' 'libtiff' 'libevent' 'yajl' 'libmariadbclient' 'lzo' 'libpng' 'python2' 'util-linux' 'freeglut' 'libjpeg-turbo' 'libtheora')
+depends=('pcre' 'libsndfile' 'libxmu' 'freetype2' 'libedit' 'libxml2' 'libtiff' 'libevent' 'yajl' 'libmariadbclient' 'lzo' 'libpng' 'python2' 'util-linux' 'freeglut' 'libjpeg-turbo' 'libtheora' 'python')
makedepends=('cmake' 'git')
options=('!makeflags' '!buildflags')
-source=("git://github.com/stevedekorte/io#tag=$pkgver"
- 'PATCH-Fix-for-inlining-in-C11-mode.patch'
- 'PATCH-added--msse2-to-compile-flags-for.patch')
-md5sums=('SKIP'
- 'a3bab046cbc4be88ec95bb22c28abab3'
- '83552f6cabb4224cbcdcc01cb3bd4b90')
+source=("git+https://github.com/stevedekorte/io#commit=5fffec7cbe9679632ff793befacedd92f79d7f0f")
+sha256sums=('SKIP')
prepare() {
- cd io
- patch -p1 -i../PATCH-Fix-for-inlining-in-C11-mode.patch
- patch -p1 -i../PATCH-added--msse2-to-compile-flags-for.patch
+ sed -i "s:20151111:${pkgver//./}:" io/libs/iovm/source/IoVersion.h
}
build() {
- cd io
- sed -i "s:20140919:${pkgver//./}:" libs/iovm/source/IoVersion.h
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ cmake ../io -DCMAKE_INSTALL_PREFIX=/usr
}
package() {
- cd io
- make -C build DESTDIR="$pkgdir" install
- install -Dm644 license/bsd_license.txt \
+ DESTDIR="$pkgdir" make -C build install
+ install -Dm644 io/license/bsd_license.txt \
"$pkgdir/usr/share/licenses/$pkgname/bsd_license.txt"
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et: