summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamantha Baldwin2016-06-15 13:42:19 -0400
committerSamantha Baldwin2016-06-15 13:42:19 -0400
commit3e512a9628d43bc7516e39024b620c290e416666 (patch)
tree982b405c30aea1cd80a539aa3c5bb9de4843f344
parent40af66b9eced2e9c2cbc51fe4783c97d81cf473c (diff)
downloadaur-ion3.tar.gz
fix build issue by requiring lua51 and providing archlinux.patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD34
-rw-r--r--archlinux.patch67
3 files changed, 87 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ae4ee507b37..306d2fa88036 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ion3
pkgdesc = Tiling tabbed window manager designed with keyboard users in mind
pkgver = 20090110
- pkgrel = 2
+ pkgrel = 3
url = http://modeemi.fi/~tuomov/ion/
arch = i686
arch = x86_64
license = custom
- depends = lua>=5.1
+ depends = lua51
depends = libx11
depends = libxext
depends = libsm
@@ -16,8 +16,10 @@ pkgbase = ion3
depends = libxdmcp
source = http://tuomov.iki.fi/software/dl/ion-3-20090110.tar.gz
source = ion3.desktop
+ source = archlinux.patch
md5sums = 1f17be1e87187b4af7de047187cc4930
md5sums = ea0c20a78da0f60463632b1149fdfeb8
+ md5sums = b1b8f5e28108d1017baf5712ddfadf75
pkgname = ion3
diff --git a/PKGBUILD b/PKGBUILD
index c9bb1a995580..482c9cae886f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,38 +3,36 @@
pkgname=ion3
pkgver=20090110
-pkgrel=2
+pkgrel=3
pkgdesc="Tiling tabbed window manager designed with keyboard users in mind"
arch=('i686' 'x86_64')
url="http://modeemi.fi/~tuomov/ion/"
license=('custom')
-depends=('lua>=5.1' 'libx11' 'libxext' 'libsm' 'libice' 'libxcb' 'libxau' 'libxdmcp')
-source=(http://tuomov.iki.fi/software/dl/ion-3-${pkgver}.tar.gz ion3.desktop)
+depends=('lua51' 'libx11' 'libxext' 'libsm' 'libice' 'libxcb' 'libxau' 'libxdmcp')
+source=(http://tuomov.iki.fi/software/dl/ion-3-${pkgver}.tar.gz
+ ion3.desktop
+ archlinux.patch)
md5sums=('1f17be1e87187b4af7de047187cc4930'
- 'ea0c20a78da0f60463632b1149fdfeb8')
+ 'ea0c20a78da0f60463632b1149fdfeb8'
+ 'b1b8f5e28108d1017baf5712ddfadf75')
-build() {
+prepare() {
cd ${srcdir}/ion-3-${pkgver}
- cp system.mk system.mk.new
- sed -e 's:PREFIX=/usr/local:PREFIX=/usr:' \
- -e 's:ETCDIR=$(PREFIX)/etc:ETCDIR=/etc:' \
- -e 's:$(PREFIX)/man:$(PREFIX)/share/man:' \
- -e 's:$(PREFIX)/doc:$(PREFIX)/share/doc:' \
- -e 's:#HAS_SYSTEM_ASPRINTF=1:HAS_SYSTEM_ASPRINTF=1:' \
- -e 's:INSTALL=.*$:INSTALL=install:' \
- -e 's:LUA_DIR=/usr/local:LUA_DIR=/usr:' \
- system.mk.new > system.mk
-
+ patch -Np2 -b -z .orig <../archlinux.patch
if [ -n "${CFLAGS}" ] ; then
cp system.mk system.mk.new
sed -e "s:CFLAGS=-Os:CFLAGS=${CFLAGS}:" system.mk.new > system.mk
fi
}
+build() {
+ cd ${srcdir}/ion-3-${pkgver}
+ make ${MAKEFLAGS}
+}
+
package() {
cd ${srcdir}/ion-3-${pkgver}
- make ${MAKEFLAGS} || return 1
- make PREFIX=${pkgdir}/usr ETCDIR=${pkgdir}/etc/ion3 install || return 1
- install -D -m644 ${startdir}/ion3.desktop ${pkgdir}/etc/X11/sessions/ion3.desktop || return 1
+ make PREFIX=${pkgdir}/usr ETCDIR=${pkgdir}/etc/ion3 install
+ install -D -m644 ${startdir}/ion3.desktop ${pkgdir}/etc/X11/sessions/ion3.desktop
install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
diff --git a/archlinux.patch b/archlinux.patch
new file mode 100644
index 000000000000..c6b555be1f9e
--- /dev/null
+++ b/archlinux.patch
@@ -0,0 +1,67 @@
+diff -up src/ion-3-20090110/system.mk.orig src/ion-3-20090110/system.mk
+--- src/ion-3-20090110/system.mk.orig 2009-01-09 15:20:27.000000000 -0700
++++ src/ion-3-20090110/system.mk 2015-07-15 05:00:19.000000000 -0600
+@@ -8,7 +8,7 @@
+
+ # Installation path prefix. Unless you know what you're doing, the default
+ # of /usr/local is likely the correct choice.
+-PREFIX=/usr/local
++PREFIX=/usr
+
+ # Unless you are creating a package conforming to some OS's standards, you
+ # probably do not want to modify the following directories:
+@@ -16,7 +16,7 @@ PREFIX=/usr/local
+ # Main binaries
+ BINDIR=$(PREFIX)/bin
+ # Configuration .lua files
+-ETCDIR=$(PREFIX)/etc/ion3
++ETCDIR=/etc/ion3
+ # Some .lua files and ion-* shell scripts
+ SHAREDIR=$(PREFIX)/share/ion3
+ # Manual pages
+@@ -62,18 +62,18 @@ DL_LIBS=-ldl
+
+ # If you have installed Lua 5.1 from the official tarball without changing
+ # paths, this should do it.
+-LUA_DIR=/usr/local
+-LUA_LIBS = -L$(LUA_DIR)/lib -llua
+-LUA_INCLUDES = -I$(LUA_DIR)/include
+-LUA=$(LUA_DIR)/bin/lua
+-LUAC=$(LUA_DIR)/bin/luac
++LUA_DIR=/usr
++#LUA_LIBS = -L$(LUA_DIR)/lib -llua
++#LUA_INCLUDES = -I$(LUA_DIR)/include
++#LUA=$(LUA_DIR)/bin/lua
++#LUAC=$(LUA_DIR)/bin/luac
+
+ # If you are using the Debian packages, the following settings should be
+ # what you want.
+-#LUA_LIBS=`pkg-config --libs lua5.1`
+-#LUA_INCLUDES=`pkg-config --cflags lua5.1`
+-#LUA=/usr/bin/lua5.1
+-#LUAC=/usr/bin/luac5.1
++LUA_LIBS=`pkg-config --libs lua51`
++LUA_INCLUDES=`pkg-config --cflags lua51`
++LUA=/usr/bin/lua5.1
++LUAC=/usr/bin/luac5.1
+
+
+ ##
+@@ -127,7 +127,7 @@ DEFINES += -DCF_XFREE86_TEXTPROP_BUG_WOR
+ # You may uncomment this if you know that your system C libary provides
+ # asprintf and vasprintf. (GNU libc does.) If HAS_SYSTEM_ASPRINTF is not
+ # defined, an implementation provided in libtu/sprintf_2.2/ is used.
+-#HAS_SYSTEM_ASPRINTF=1
++HAS_SYSTEM_ASPRINTF=1
+
+ # The following setting is needed with GNU libc for clock_gettime and the
+ # monotonic clock. Other systems may not need it, or may not provide a
+@@ -207,7 +207,7 @@ RANLIB=ranlib
+ ## Install & strip
+ ##
+
+-INSTALL=sh $(TOPDIR)/install-sh -c
++INSTALL=install
+ INSTALL_STRIP=-s
+ INSTALLDIR=mkdir -p
+