summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimón Oroño2016-10-22 10:19:13 -0400
committerSimón Oroño2016-10-22 10:19:13 -0400
commit49c3a0e28c5d504bf91416f7b49d089df2ac29b4 (patch)
tree844c03854d36d030bb75ebfb3e9bc954c1e172ac
parenta5cb45d05ce3e46b74f919282b673f73934f83f6 (diff)
downloadaur-49c3a0e28c5d504bf91416f7b49d089df2ac29b4.tar.gz
Updated to v2.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4a778edb03f..35a610ee209e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = iop-blockchain
pkgdesc = IoP is the digital currency from the Internet of People that enables instant payments to anyone, anywhere in the world.
- pkgver = 1.2.0b
+ pkgver = 2.0.0
pkgrel = 1
url = http://www.fermat.org/
arch = i686
@@ -21,8 +21,8 @@ pkgbase = iop-blockchain
depends = qrencode
depends = protobuf
depends = zeromq
- source = https://github.com/Fermat-ORG/iop-blockchain/archive/beta-1.0.0.zip
- sha256sums = SKIP
+ source = https://github.com/Fermat-ORG/iop-blockchain/archive/81335ba210c0cf79757c22dfd66ff9142de7ea8f.zip
+ sha256sums = 16879eeb89dfa16d1af7c6cc75203659c8595926848dc03b3d14609c3b804a72
pkgname = iop-blockchain
diff --git a/PKGBUILD b/PKGBUILD
index 2267121780d1..923ab4aad837 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Simón Oroño <sron611@gmail.com>
pkgname='iop-blockchain'
-pkgver=1.2.0b
+pkgver=2.0.0
pkgrel=1
pkgbase="$pkgname"
pkgdesc="IoP is the digital currency from the Internet of People that enables instant payments to anyone, anywhere in the world."
@@ -10,18 +10,18 @@ url="http://www.fermat.org/"
makedepends=('git' 'boost' 'libevent' 'qt5-base' 'qt5-tools' 'qrencode' 'protobuf' 'zeromq')
depends=(boost-libs desktop-file-utils libevent qt5-base qrencode protobuf zeromq)
license=('MIT')
-source=(https://github.com/Fermat-ORG/iop-blockchain/archive/beta-1.0.0.zip)
-sha256sums=('SKIP')
+source=(https://github.com/Fermat-ORG/iop-blockchain/archive/81335ba210c0cf79757c22dfd66ff9142de7ea8f.zip)
+sha256sums=('16879eeb89dfa16d1af7c6cc75203659c8595926848dc03b3d14609c3b804a72')
build() {
- cd "$pkgbase-beta-1.0.0"
+ cd "$pkgbase-81335ba210c0cf79757c22dfd66ff9142de7ea8f"
./autogen.sh
./configure --prefix=/usr --with-gui=qt5 --with-incompatible-bdb
make
}
package() {
- cd "$pkgbase-beta-1.0.0"
+ cd "$pkgbase-81335ba210c0cf79757c22dfd66ff9142de7ea8f"
install -Dm755 src/qt/IoP-qt "$pkgdir"/usr/bin/IoP-qt
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"