summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimón Oroño2017-02-14 08:48:29 -0400
committerSimón Oroño2017-02-14 08:48:29 -0400
commitcca967b20679047495894c53d122cee9542001a5 (patch)
tree79ea1c5145b7201349341a533a5da0bf21ece497
downloadaur-cca967b20679047495894c53d122cee9542001a5.tar.gz
New package
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD29
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..776ae447aad2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = iop-token
+ pkgdesc = IoP is the digital currency from the Internet of People that enables instant payments to anyone, anywhere in the world.
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = http://www.fermat.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = boost
+ makedepends = libevent
+ makedepends = qt5-base
+ makedepends = qt5-tools
+ makedepends = qrencode
+ makedepends = protobuf
+ makedepends = zeromq
+ depends = boost-libs
+ depends = desktop-file-utils
+ depends = libevent
+ depends = qt5-base
+ depends = qrencode
+ depends = protobuf
+ depends = zeromq
+ source = https://github.com/Fermat-ORG/iop-token/archive/a557231f4a4200960e5606bcf0e07cee63f65d6d.zip
+ sha256sums = 53791fe15d1891fd68ba048f331f9bd8b6cd60aa59cfcc6db1fbca447bf6c643
+
+pkgname = iop-token
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0af4b19e74ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Simón Oroño <simonorono@protonmail.com>
+
+pkgname='iop-token'
+pkgver=3.0.1
+pkgrel=1
+pkgbase="$pkgname"
+pkgdesc="IoP is the digital currency from the Internet of People that enables instant payments to anyone, anywhere in the world."
+arch=('i686' 'x86_64')
+url="http://www.fermat.org/"
+makedepends=('git' 'boost' 'libevent' 'qt5-base' 'qt5-tools' 'qrencode' 'protobuf' 'zeromq')
+depends=(boost-libs desktop-file-utils libevent qt5-base qrencode protobuf zeromq)
+license=('MIT')
+source=(https://github.com/Fermat-ORG/iop-token/archive/a557231f4a4200960e5606bcf0e07cee63f65d6d.zip)
+sha256sums=('53791fe15d1891fd68ba048f331f9bd8b6cd60aa59cfcc6db1fbca447bf6c643')
+
+build() {
+ cd "iop-token-a557231f4a4200960e5606bcf0e07cee63f65d6d"
+ ./autogen.sh
+ ./configure --prefix=/usr --with-gui=qt5 --with-incompatible-bdb
+ make -j 2
+}
+
+package() {
+ cd "iop-token-a557231f4a4200960e5606bcf0e07cee63f65d6d"
+ install -Dm755 src/qt/IoP-qt "$pkgdir"/usr/bin/IoP-qt
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+