summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2014-01-05 16:09:34 -0500
committerSlashbunny2014-01-05 16:09:34 -0500
commit071718bde0fd389f77ac40e0434a0a3e8eb274be (patch)
tree002baa8f4061261fea974302cca6ac4ce2f4e08d
parent3cdbb1d32edae4d4a4e3fdbce06f90a43817dccd (diff)
downloadaur-071718bde0fd389f77ac40e0434a0a3e8eb274be.tar.gz
More ioquake3 build improvements, remove legacy launchers
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD90
-rw-r--r--quake3.install17
-rw-r--r--quake3.launcher5
-rw-r--r--quake3ded.launcher5
5 files changed, 66 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb5bb489546a..a16e4f1e2fa0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,8 +9,15 @@ pkgbase = ioquake3-git
license = GPL
makedepends = nasm
makedepends = git
- depends = sdl
+ depends = curl
+ depends = freetype2
+ depends = libjpeg
+ depends = libvorbis
depends = openal
+ depends = sdl
+ depends = speex
+ depends = zlib
+ optdepends = mumble
provides = quake3
provides = ioquake3
conflicts = quake3
@@ -20,13 +27,9 @@ pkgbase = ioquake3-git
replaces = quake3-icculus-svn
replaces = ioquake3-svn
source = quake3.desktop
- source = quake3.launcher
- source = quake3ded.launcher
source = http://ftp.gwdg.de/pub/misc/ftp.idsoftware.com/idstuff/quake3/linux/linuxq3apoint-1.32b-3.x86.run
source = quake3::git://github.com/ioquake/ioq3.git
sha256sums = 12dbd31e9de1493642d120bfd1548dfc4935e47fec806003cfc04b9d84b85673
- sha256sums = 7f0806379b10a6cff248b647aeb67d89a8e954e51e7a633cfadeca9865d125e7
- sha256sums = 7f0806379b10a6cff248b647aeb67d89a8e954e51e7a633cfadeca9865d125e7
sha256sums = c36132c5556b35e01950f1e9c646235033a5130f87ad776ba2bc7becf4f4f186
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ad5c18cfd84f..d1f60a54c39a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+# Maintainer: Slash <demodevil5[at]yahoo[dot]com>
+# Contributors: OttoA (AUR), hoschi (AUR), samlt (AUR), andreyv (AUR)
pkgname=ioquake3-git
pkgver=20131217.gbc2efc4
@@ -7,18 +8,17 @@ pkgdesc="The de-facto OSS Quake 3 distribution. You need the retail/demo .pk3 fi
url="http://ioquake3.org/"
license=('GPL')
arch=('i686' 'x86_64')
-depends=('sdl' 'openal')
+depends=('curl' 'freetype2' 'libjpeg' 'libvorbis' 'openal' 'sdl' 'speex' 'zlib')
makedepends=('nasm' 'git')
+optdepends=('mumble')
conflicts=('quake3' 'quake3-icculus-svn' 'quake3-svn' 'ioquake3-svn')
provides=('quake3' 'ioquake3')
replaces=('quake3-icculus-svn' 'ioquake3-svn')
install=quake3.install
-source=('quake3.desktop' 'quake3.launcher' 'quake3ded.launcher' \
+source=('quake3.desktop' \
'http://ftp.gwdg.de/pub/misc/ftp.idsoftware.com/idstuff/quake3/linux/linuxq3apoint-1.32b-3.x86.run'
'quake3::git://github.com/ioquake/ioq3.git')
sha256sums=('12dbd31e9de1493642d120bfd1548dfc4935e47fec806003cfc04b9d84b85673'
- '7f0806379b10a6cff248b647aeb67d89a8e954e51e7a633cfadeca9865d125e7'
- '7f0806379b10a6cff248b647aeb67d89a8e954e51e7a633cfadeca9865d125e7'
'c36132c5556b35e01950f1e9c646235033a5130f87ad776ba2bc7becf4f4f186'
'SKIP')
@@ -29,48 +29,57 @@ pkgver() {
}
prepare() {
- cd "${srcdir}/quake3"
+ cd "${srcdir}"
+
+ # Extract Patch Files
+ chmod +x "${srcdir}/linuxq3apoint-1.32b-3.x86.run"
+ "${srcdir}/linuxq3apoint-1.32b-3.x86.run" --tar xf
+}
- # Patch Makefile to correct install path
- /bin/sed -i "s:/usr/local/games/quake3:${pkgdir}/opt/quake3:" Makefile
+q3make() {
+ make $@ \
+ BUILD_CLIENT=1 \
+ BUILD_SERVER=1 \
+ BUILD_BASEGAME=0 \
+ BUILD_MISSIONPACK=0 \
+ BUILD_GAME_SO=0 \
+ BUILD_GAME_QVM=0 \
+ BUILD_RENDERER_OPENGL2=1 \
+ DEFAULT_BASEDIR="/opt/quake3" \
+ FULLBINEXT='' \
+ GENERATE_DEPENDENCIES=0 \
+ OPTIMIZE='' \
+ USE_OPENAL=1 \
+ USE_OPENAL_DLOPEN=0 \
+ USE_CURL=1 \
+ USE_CURL_DLOPEN=0 \
+ USE_CODEC_VORBIS=1 \
+ USE_CODEC_OPUS=0 \
+ USE_FREETYPE=1 \
+ USE_MUMBLE=1 \
+ USE_VOIP=1 \
+ USE_INTERNAL_SPEEX=0 \
+ USE_INTERNAL_ZLIB=0 \
+ USE_INTERNAL_JPEG=0 \
+ USE_INTERNAL_OGG=0 \
+ USE_INTERNAL_OPUS=0 \
+ USE_LOCAL_HEADERS=0
}
build() {
cd "${srcdir}/quake3"
- # Compile ioQuake3
- make
+ q3make
}
package() {
cd "${srcdir}/quake3"
- # Install Files
- make copyfiles
+ # Create Destination Directories
+ install -d "${pkgdir}"/{usr/bin,/opt/quake3/{baseq3,missionpack,demoq3}}
- # Extract Patch Files
- cd "${srcdir}"
- chmod +x "${srcdir}/linuxq3apoint-1.32b-3.x86.run"
- "${srcdir}/linuxq3apoint-1.32b-3.x86.run" --tar xf
-
- # Modify Launcher Scripts
- if [ "$CARCH" = "x86_64" ]; then
- #
- # x86_64 Systems
- #
- /bin/sed -i "s:IOQ3_BINARY:ioquake3.x86_64:" \
- "${srcdir}/quake3.launcher"
- /bin/sed -i "s:IOQ3_BINARY:ioq3ded.x86_64:" \
- "${srcdir}/quake3ded.launcher"
- else
- #
- # i686 Systems
- #
- /bin/sed -i "s:IOQ3_BINARY:ioquake3.i386:" \
- "${srcdir}/quake3.launcher"
- /bin/sed -i "s:IOQ3_BINARY:ioq3ded.i386:" \
- "${srcdir}/quake3ded.launcher"
- fi
+ # Install Files
+ q3make COPYDIR="${pkgdir}/opt/quake3" copyfiles
# Install Quake 3 Patch Files
install -m 644 "${srcdir}"/baseq3/*.pk3 \
@@ -80,13 +89,12 @@ package() {
install -m 644 "${srcdir}"/missionpack/*.pk3 \
"${pkgdir}/opt/quake3/missionpack/"
- # Install Launcher (Client)
- install -D -m 755 "${srcdir}/quake3.launcher" \
- "${pkgdir}/usr/bin/quake3"
+ # Link pk3 files to demoq3
+ ln -sf /opt/quake3/baseq3/pak{1..8}.pk3 "${pkgdir}/opt/quake3/demoq3/"
- # Install Launcher (Server)
- install -D -m 755 "${srcdir}/quake3ded.launcher" \
- "${pkgdir}/usr/bin/quake3ded"
+ # Link Executables in /usr/bin
+ ln -sf "/opt/quake3/ioquake3" "${pkgdir}/usr/bin/quake3"
+ ln -sf "/opt/quake3/ioq3ded" "${pkgdir}/usr/bin/q3ded"
# Install Desktop File
install -D -m 644 "${srcdir}/quake3.desktop" \
diff --git a/quake3.install b/quake3.install
index 3e40253fbe8e..c64cd8056c63 100644
--- a/quake3.install
+++ b/quake3.install
@@ -1,19 +1,20 @@
post_install() {
echo ">>>"
- echo ">>>>To play Q3 with the Retail Version:"
- echo ">>> Move the pak0.pk3 file from the original game CD to"
+ echo ">>> To play Q3 with the Retail Version:"
+ echo ">>> Move the pak0.pk3 file from the original game CD to:"
echo ">>> /opt/quake3/baseq3/"
echo ">>>"
- echo ">>>>To play Q3 with the Demo Version:"
- echo ">>> You need the demoq3/pak0.pk3 from the demo installer. The"
- echo ">>> qvm files inside that pk3 file will not work, so you have"
- echo ">>> to copy or link the .so files in the baseq3/ directory to"
- echo ">>> /opt/quake3/demoq3/ with the pak0.pk3 file."
+ echo ">>> To play Q3 with the Demo Version:"
+ echo ">>> Move the demoq3/pak0.pk3 from the demo installer to:"
+ echo ">>> /opt/quake3/demoq3/"
echo ">>>"
- echo ">>>>When you have the .pk3 file(s) installed, run the game:"
+ echo ">>> When you have the .pk3 file(s) installed, run the game:"
echo ">>> quake3"
echo ">>>"
+ echo ">>> Or for the Demo Version:"
+ echo ">>> quake3 +set fs_game demoq3"
+ echo ">>>"
}
post_upgrade() {
diff --git a/quake3.launcher b/quake3.launcher
deleted file mode 100644
index c9b092bea99c..000000000000
--- a/quake3.launcher
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/bash
-
-cd "/opt/quake3"
-exec ./IOQ3_BINARY $*
-
diff --git a/quake3ded.launcher b/quake3ded.launcher
deleted file mode 100644
index c9b092bea99c..000000000000
--- a/quake3ded.launcher
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/bash
-
-cd "/opt/quake3"
-exec ./IOQ3_BINARY $*
-