summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2018-11-19 17:05:14 +0100
committerGianluca Boiano2018-11-19 17:05:14 +0100
commitcf7757b5a67a08bce4390022a2ad3f8a3866ec52 (patch)
tree7faeddccf800e3355f61ba34c141214448e234cf
downloadaur-cf7757b5a67a08bce4390022a2ad3f8a3866ec52.tar.gz
iortcw-venom-mod: first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23f25bda1804
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = iortcw-venom-mod
+ pkgdesc = Venom Mod is a general improvement of original Rtcw game, with a new challenging and aggressive AI and some exploitation of features of id tech 3 engine, keeping the original gameplay
+ pkgver = 5.5
+ pkgrel = 1
+ url = https://www.moddb.com/mods/rtcw-venom-mod
+ arch = any
+ license = CUSTOM
+ makedepends = unrar
+ depends = iortcw-git
+ noextract = Venom_Mod_v5.5.rar
+ source = http://www.wolfenstein-files.de/rtcw/single/Venom_Mod_v5.5.rar
+ md5sums = 0c2e76b606600ba58db634930dcbf137
+
+pkgname = iortcw-venom-mod
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c247bfbeac8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: robertfoster
+
+pkgname=iortcw-venom-mod
+pkgver=5.5
+pkgrel=1
+epoch=
+pkgdesc="Venom Mod is a general improvement of original Rtcw game, with a new challenging and aggressive AI and some exploitation of features of id tech 3 engine, keeping the original gameplay"
+arch=(any)
+url="https://www.moddb.com/mods/rtcw-venom-mod"
+license=('CUSTOM')
+depends=('iortcw-git')
+makedepends=('unrar')
+source=("http://www.wolfenstein-files.de/rtcw/single/Venom_Mod_v$pkgver.rar")
+noextract=("Venom_Mod_v$pkgver.rar")
+md5sums=('bc6c1f5ecd2ced42b05657dad8f873a8')
+
+package() {
+ cd "$srcdir"
+ unrar -o+ e "Venom_Mod_v$pkgver.rar"
+ for i in $(ls *.pk3); do
+ install -Dm755 $i $pkgdir/opt/iortcw/Venom\ Mod/$i
+ done
+ install -Dm755 autoexec.cfg $pkgdir/opt/iortcw/Venom\ Mod/autoexec.cfg
+}
+
+md5sums=('0c2e76b606600ba58db634930dcbf137')