summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2020-10-31 14:24:00 +0100
committerGianluca Boiano2020-10-31 14:24:00 +0100
commite08e119246c6cb9428457aa3b8a1fe14b72eb852 (patch)
tree0db0fd54a88211832b048879cd8ef4f61e4590e8
parent43463def2a6c8ec23ecb4d99e30f29472252b582 (diff)
downloadaur-e08e119246c6cb9428457aa3b8a1fe14b72eb852.tar.gz
iortcw-venom-mod: 6.5.6 wih RealRTCW compatibility
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
2 files changed, 23 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d545b0fafbde..a933be2419c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = iortcw-venom-mod
pkgdesc = Venom Mod is a general improvement of original Rtcw game, with a new challenging and aggressive AI and some exploitation of features of id tech 3 engine, keeping the original gameplay
- pkgver = 6.5.2
+ pkgver = 6.5.6
pkgrel = 1
url = https://www.moddb.com/mods/rtcw-venom-mod
arch = any
license = CUSTOM
- makedepends = unrar
- depends = iortcw-git
- noextract = iortcw-venom-mod-6.5.2.rar
- source = iortcw-venom-mod-6.5.2.rar::https://www.moddb.com/downloads/mirror/173653/121/fb58577d8b90d4709641f703718cf35e
- md5sums = da120236f395e865e6ff379768b06d58
+ makedepends = unzip
+ depends = iortcw-data
+ noextract = iortcw-venom-mod-6.5.6.zip
+ source = iortcw-venom-mod-6.5.6.zip::https://www.moddb.com/downloads/mirror/173653/119/c90d40bdbeea743b5f31f401391f3ce4
+ md5sums = 1eb9a668b79d3d3a675eb57af192e283
pkgname = iortcw-venom-mod
diff --git a/PKGBUILD b/PKGBUILD
index 29150ad1d1dd..815b90bf81a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,29 @@
# Maintainer: robertfoster
pkgname=iortcw-venom-mod
-pkgver=6.5.2
+pkgver=6.5.6
pkgrel=1
pkgdesc="Venom Mod is a general improvement of original Rtcw game, with a new challenging and aggressive AI and some exploitation of features of id tech 3 engine, keeping the original gameplay"
arch=(any)
url="https://www.moddb.com/mods/rtcw-venom-mod"
license=('CUSTOM')
-depends=('iortcw-git')
-makedepends=('unrar')
-noextract=("$pkgname-$pkgver.rar")
-source=("$pkgname-$pkgver.rar::https://www.moddb.com/downloads/mirror/173653/121/fb58577d8b90d4709641f703718cf35e")
+depends=('iortcw-data')
+makedepends=('unzip')
+noextract=("$pkgname-$pkgver.zip")
+source=("$pkgname-$pkgver.zip::https://www.moddb.com/downloads/mirror/173653/119/c90d40bdbeea743b5f31f401391f3ce4")
+
+prepare() {
+ # Unzipping with flattened paths
+ unzip -jo $pkgname-$pkgver.zip -d paks
+}
package() {
- cd "$srcdir"
- unrar e -o+ "$pkgname-$pkgver.rar"
- for i in $(ls *.pk3); do
- install -Dm644 $i $pkgdir/opt/iortcw/Venom\ Mod/$i
- done
- install -Dm644 autoexec.cfg $pkgdir/opt/iortcw/Venom\ Mod/autoexec.cfg
+ cd "$srcdir"/paks
+ find . -iname "*.pk3" -exec install -Dm644 {} "$pkgdir/opt/iortcw/Venom\ Mod/"{} \;
+ install -Dm644 autoexec.cfg "$pkgdir/opt/iortcw/Venom\ Mod/autoexec.cfg"
+ # RealRTCW compatibility
+ mkdir -p "$pkgdir/opt/realrtcw"
+ ln -sr /opt/iortcw/Venom\ Mod "$pkgdir/opt/realrtcw/Venom\ Mod"
}
-md5sums=('da120236f395e865e6ff379768b06d58')
+md5sums=('1eb9a668b79d3d3a675eb57af192e283')